From 9282223de4b511aeda3b7d2caf3810a56a865710 Mon Sep 17 00:00:00 2001 From: kiasoc5 Date: Mon, 10 Jan 2022 14:16:32 -0500 Subject: [PATCH] Use C locale unconditionally for tests. MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit The ‘en_US.utf8’ locale is available. However, the ‘locale -a’ command won’t list it. --- tests/libtest-core.sh | 7 +------ 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/tests/libtest-core.sh b/tests/libtest-core.sh index 9632e90..82951dd 100644 --- a/tests/libtest-core.sh +++ b/tests/libtest-core.sh @@ -41,12 +41,7 @@ assert_not_reached () { # # If we can't find the locale command assume we have support for C.UTF-8 # (e.g. musl based systems) -if type -p locale >/dev/null; then - export LC_ALL=$(locale -a | grep -iEe '^(C|en_US)\.(UTF-8|utf8)$' | head -n1 || true) - if [ -z "${LC_ALL}" ]; then fatal "Can't find suitable UTF-8 locale"; fi -else - export LC_ALL=C.UTF-8 -fi +export LC_ALL=en_US.utf8 # A GNU extension, used whenever LC_ALL is not C unset LANGUAGE -- 2.34.1 ccd178c9d6b'>refslogtreecommitdiff
path: root/gnu/packages/upnp.scm
AgeCommit message (Expand)Author
2021-01-06gnu: upnp.scm: Sort package module imports alphabetically....* gnu/packages/upnp.scm: Sort package module imports alphabetically. Efraim Flashner
2021-01-06gnu: readymedia: Sort inputs alphabetically....* gnu/packages/upnp.scm (readymedia)[native-inputs]: Sort alphabetically. [inputs]: Same. Efraim Flashner
2021-01-06gnu: readymedia: Update to 1.3.0....Fixes CVE-2020-28926. * gnu/packages/upnp.scm (readymedia): Update to 1.3.0. [arguments]: Add configure-flag to not record kernel version of build machine. Add phase to remove spurious substitution of ffmpeg libraries. [inputs]: Add zlib. Efraim Flashner
2021-01-06gnu: upnp.scm: Use license prefix....* gnu/packages/upnp.scm: Use the 'license:' prefix to denote licences. Efraim Flashner
2021-01-06gnu: readymedia: Clean-up origin code....* gnu/packages/upnp.scm (readymedia)[source]: Replace custom logic with string-replace-substring. Efraim Flashner
2020-12-31gnu: libupnp: Update to 1.14.0....* gnu/packages/upnp.scm (libupnp): Update to 1.14.0. Signed-off-by: Leo Famulari <leo@famulari.name> Vincent Legoll
2020-05-13gnu: libupnp: Do not build static libraries....* gnu/packages/upnp.scm (libupnp)[arguments]: Add "--disable-static" in #:configure-flags. Also remove "--enable-ipv6" as it is the default. Marius Bakke
2020-05-13gnu: libupnp: Update to 1.12.1....* gnu/packages/upnp.scm (libupnp): Update to 1.12.1. [source]: Change to URL-FETCH with bootstrapped tarball. [native-inputs]: Remove AUTOCONF, AUTOMAKE, and LIBTOOL. Marius Bakke
2020-05-02Merge branch 'master' into core-updatesMarius Bakke
2020-05-02gnu: libupnp: Update to 1.8.6....* gnu/packages/upnp.scm (libupnp): Update to 1.8.6. [source]: Use git-fetch on the new official repository. [native-inputs]: Add autoconf, automake, libtool and pkg-config. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Jan Wielkiewicz