diff --git a/hunt/hunt/hunt.c b/hunt/hunt/hunt.c index 11f4c44..28321bc 100644 --- a/hunt/hunt/hunt.c +++ b/hunt/hunt/hunt.c @@ -394,7 +394,8 @@ broadcast_vec(s, vector) vec_cnt = 0; for (ip = ifp; ip; ip = ip->ifa_next) - if ((ip->ifa_addr->sa_family == AF_INET) && + if (ip->ifa_addr && + (ip->ifa_addr->sa_family == AF_INET) && (ip->ifa_flags & IFF_BROADCAST)) vec_cnt++; @@ -405,7 +406,8 @@ broadcast_vec(s, vector) vec_cnt = 0; for (ip = ifp; ip; ip = ip->ifa_next) - if ((ip->ifa_addr->sa_family == AF_INET) && + if (ip->ifa_addr && + (ip->ifa_addr->sa_family == AF_INET) && (ip->ifa_flags & IFF_BROADCAST)) memcpy(&(*vector)[vec_cnt++], ip->ifa_broadaddr, sizeof(struct sockaddr_in)); lected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/build-aux
AgeCommit message (Expand)Author
2024-07-18guix: channels: Enable specifiying available builtin builders....Christopher Baines
2024-04-19maint: Generate doc/version[-LANG].texi using `mdate-from-git.scm'....Janneke Nieuwenhuizen
2024-04-19maint: Support `make doc-pot-update' from a tarball....Janneke Nieuwenhuizen
2024-04-14maint: Fix header....Janneke Nieuwenhuizen
2024-04-14maint: Use xgettext.scm wrapper to create .PO files reproducibly....Janneke Nieuwenhuizen
2024-01-05build: test-driver.scm: Set mode....Tomas Volf
2023-08-21maint: Add 'etc/hurd-manifest.scm'....Janneke Nieuwenhuizen
2023-07-25cuirass: Update hurd-manifest with newly supported packages....Janneke Nieuwenhuizen
2022-05-26cuirass: Create just as many threads as needed....Ludovic Courtès
2022-05-26cuirass: Fork inferior processes before creating threads....Ludovic Courtès
2022-05-20cuirass: Close each inferior upon completion....Ludovic Courtès
2021-12-22tests: Move keys into ./tests/keys/ and add a third ed25519 key....Attila Lendvai
2021-11-27build-self: Help users to submit useful bug reports....Tobias Geerinckx-Rice
2021-10-17maint: Factorize po xref translation....Julien Lepiller
2021-06-23build: Makefile splits Scheme compilation in four steps....Ludovic Courtès
2021-06-18build: Remove Guile 2.2 workaround....Ludovic Courtès