diff --git a/hunt/hunt/playit.c b/hunt/hunt/playit.c
index 9acf86e..881a4e7 100644
--- a/hunt/hunt/playit.c
+++ b/hunt/hunt/playit.c
@@ -114,7 +114,7 @@ playit()
bad_con();
/* NOTREACHED */
}
- if (ntohl(version) != (unsigned long)HUNT_VERSION) {
+ if (ntohl(version) != (uint32_t)HUNT_VERSION) {
bad_ver();
/* NOTREACHED */
}
@@ -649,7 +649,7 @@ do_message()
bad_con();
/* NOTREACHED */
}
- if (ntohl(version) != (unsigned long)HUNT_VERSION) {
+ if (ntohl(version) != (uint32_t)HUNT_VERSION) {
bad_ver();
/* NOTREACHED */
}
uix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-06-05 | gnu: ldc: Fix building on riscv64-linux....* gnu/packages/dlang.scm (ldc)[arguments]: Add a configure-flag to link
the executables with -latomic. Adjust the 'disable-problematic-tests
phase to disable 2 tests which fail on riscv64-linux and delete some
tests which fail on riscv64-linux. Adjust the custom 'check phase to
skip several tests when building on riscv64-linux.
Change-Id: I38a87b053c1399fa7762b4843555d6e2afc20427
| Efraim Flashner |
2024-06-05 | gnu: ldc: Build with llvm-17....* gnu/packages/dlang.scm (ldc-bootstrap)[native-inputs]: Replace
lld-wrapper-15 with lld-wrapper-17, llvm-15 with llvm-17.
(ldc)[native-inputs]: Replace clang-15 with clang-17.
Change-Id: I8d5b19d3da52ba9f2d1fa3afcabe74ad4ce1d5e1
| Efraim Flashner |
2024-06-05 | gnu: ldc: Fix build on aarch64-linux....* gnu/packages/dlang.scm (ldc)[arguments]: Don't delete tests which
don't fail on aarch64-linux. Adjust custom 'check phase to skip some
tests known to fail on aarch64-linux.
Change-Id: I84ea2f356a44e12952dbb852e41921895605176a
| Efraim Flashner |
2024-06-05 | gnu: ldc: Honor parallel-build?....* gnu/packages/dlang.scm (ldc-bootstrap)[arguments]: Adjust custom
'build phase to check parallel-build? and not parallel-tests?.
Change-Id: I84b5f5153fea89d80564f5a55c8df57ff201ee69
| Efraim Flashner |
2024-06-05 | gnu: ldc: Update to 1.38.0....* gnu/packages/dlang.scm (ldc-bootstrap): Update to 1.38.0.
(ldc)[arguments]: Adjust 'patch-paths-in-tests phase for changes in the
test suite. Adjust 'disable-problematic-tests phase to change the
skipped tests.
Change-Id: I5315ed5d3fc7d08a97aa0b5677692fbf221bf0c1
| Efraim Flashner |