This package requires CMAKE_MODULE_PATH be set by the calling process. This
patch uses the CMAKE_PREFIX_PATH passed from Guix as the search path for
locating the bloomberg-bde-tools CMake modules.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ else()
if (NOT CMAKE_MODULE_PATH)
message(FATAL "Please specify path to BDE cmake modules.")
endif()
+ string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
include(bde_workspace)
='main'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |