Enable the workaround for the Loongson 2F bug by default. Patch by Mark H Weaver . --- binutils/gas/config/tc-mips.c.orig 2012-09-04 10:21:03.000000000 -0400 +++ binutils/gas/config/tc-mips.c 2013-10-06 02:23:21.651983768 -0400 @@ -934,10 +934,10 @@ enum fix_vr4120_class }; /* ...likewise -mfix-loongson2f-jump. */ -static bool mips_fix_loongson2f_jump; +static bool mips_fix_loongson2f_jump = FALSE; /* ...likewise -mfix-loongson2f-nop. */ -static bool mips_fix_loongson2f_nop; +static bool mips_fix_loongson2f_nop = TRUE; /* True if -mfix-loongson2f-nop or -mfix-loongson2f-jump passed. */ static bool mips_fix_loongson2f; --- binutils/gas/testsuite/gas/mips/mips.exp.orig 2012-09-04 10:17:13.000000000 -0400 +++ binutils/gas/testsuite/gas/mips/mips.exp 2013-10-06 02:23:21.663983768 -0400 @@ -110,6 +110,12 @@ proc mips_arch_init {} { # Catch because the variable won't be set the first time through. catch {unset mips_arches} + + # Disable the loongson2f nop fix by default, because most of the + # existing test cases for mips will fail otherwise. + global ASFLAGS + set old_ASFLAGS "$ASFLAGS" + set ASFLAGS "$ASFLAGS -mno-fix-loongson2f-nop" } # mips_arch_create ARCH GPRSIZE EXTENDS PROPS AS_FLAGS OBJDUMP_FLAGS \ 9756658e5'>treecommitdiff
path: root/build-aux/test-env.in
AgeCommit message (Expand)Author
2021-12-22tests: Move keys into ./tests/keys/ and add a third ed25519 key....Attila Lendvai
2021-04-20import: Remove Nix importer....Ludovic Courtès
2019-10-16build: Remove references to 'NIX_LOCALSTATE_DIR'....Ludovic Courtès
2019-10-16daemon: Remove traces of 'NIX_ROOT_FINDER'....Ludovic Courtès
2019-02-04daemon: Rename 'NIX_STATE_DIR' and 'NIX_DB_DIR' environment variables....Ludovic Courtès
2018-05-13build: 'test-env' does not 'guix download' non-existent files....Ludovic Courtès
2018-04-22build: Fix possible race condition in 'test-env'....Ludovic Courtès
2017-08-28build: Remove code to download the Guile bootstrap tarball....Ludovic Courtès