Enable the workaround for the Loongson 2F bug by default. Patch by Mark H Weaver . --- binutils/gas/config/tc-mips.c.orig 2012-09-04 10:21:03.000000000 -0400 +++ binutils/gas/config/tc-mips.c 2013-10-06 02:23:21.651983768 -0400 @@ -934,10 +934,10 @@ enum fix_vr4120_class }; /* ...likewise -mfix-loongson2f-jump. */ -static bool mips_fix_loongson2f_jump; +static bool mips_fix_loongson2f_jump = FALSE; /* ...likewise -mfix-loongson2f-nop. */ -static bool mips_fix_loongson2f_nop; +static bool mips_fix_loongson2f_nop = TRUE; /* True if -mfix-loongson2f-nop or -mfix-loongson2f-jump passed. */ static bool mips_fix_loongson2f; --- binutils/gas/testsuite/gas/mips/mips.exp.orig 2012-09-04 10:17:13.000000000 -0400 +++ binutils/gas/testsuite/gas/mips/mips.exp 2013-10-06 02:23:21.663983768 -0400 @@ -110,6 +110,12 @@ proc mips_arch_init {} { # Catch because the variable won't be set the first time through. catch {unset mips_arches} + + # Disable the loongson2f nop fix by default, because most of the + # existing test cases for mips will fail otherwise. + global ASFLAGS + set old_ASFLAGS "$ASFLAGS" + set ASFLAGS "$ASFLAGS -mno-fix-loongson2f-nop" } # mips_arch_create ARCH GPRSIZE EXTENDS PROPS AS_FLAGS OBJDUMP_FLAGS \ 63caf'>treecommitdiff
path: root/gnu/packages/mes.scm
AgeCommit message (Expand)Author
2021-05-29gnu: nyacc: Update to 1.04.0....* gnu/packages/mes.scm (nyacc): Update to 1.04.0. Ricardo Wurmus
2021-03-29gnu: nyacc: Update to 1.03.6....* gnu/packages/mes.scm (nyacc): Update to 1.03.6. Signed-off-by: Christopher Baines <mail@cbaines.net> Xinglu Chen
2021-03-14gnu: mes: Remove aarch64-linux from supported-systems....* gnu/packages/mes.scm (mes)[supported-systems]: Remove aarch64-linux. Thinko: mes only builds on aarch64-linux using --system=armhf-linux. Jan (janneke) Nieuwenhuizen
2021-03-14gnu: mescc-tools: Build for armhf-linux and aarch64-linux too....* gnu/packages/mes.scm (mescc-tools)[supported-systems]: New field, overriding the v0.5.2 version. Jan (janneke) Nieuwenhuizen
2021-03-14gnu: mes: Update to 0.23....* gnu/packages/mes.scm (mes)[source]: Update to 0.23. [supported-systems]: Add aarch64-linux, armhf-linux. (mes-rb5)[version,source,supported-systems]: Revert to v0.22. Jan (janneke) Nieuwenhuizen
2021-03-14gnu: mes: Update to nyacc-1.00.2....* gnu/packages/mes.scm (mes)[propagated-inputs]: Use nyacc-1.00.2. Jan (janneke) Nieuwenhuizen
2021-03-14gnu: Add nyacc-1.00.2....* gnu/packages/mes.scm (nyacc-1.00.2): New variable. Jan (janneke) Nieuwenhuizen
2021-03-14gnu: mescc-tools: Update to 0.7.0....* gnu/packages/mes.scm (mescc-tools)[source]: Update to 0.7.0. [arguments]: Add patch-prefix phase to remove hardcoded "/usr/bin". Jan (janneke) Nieuwenhuizen