From 2a9b15aefb842a734637f3d230936ea1b7c60096 Mon Sep 17 00:00:00 2001 From: Philip Kime Date: Thu, 8 Nov 2018 22:02:09 +0100 Subject: [PATCH] Fix to address #239 --- lib/Biber.pm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/lib/Biber.pm b/lib/Biber.pm index 8b1f80a5..d97fca29 100644 --- a/lib/Biber.pm +++ b/lib/Biber.pm @@ -311,6 +311,8 @@ sub parse_ctrlfile { unless (eval {$checkbuf = File::Slurper::read_text($ctrl_file_path, 'latin1')}) { biber_error("$ctrl_file_path is not UTF-8 or even latin1, how horrible."); } + # Write ctrl file as UTF-8 + File::Slurper::write_text($ctrl_file_path, NFC($checkbuf));# Unicode NFC boundary } $checkbuf = NFD($checkbuf);# Unicode NFD boundary @@ -319,8 +321,6 @@ sub parse_ctrlfile { unlink($output) unless $output eq '-';# ignore deletion of STDOUT marker biber_error("$ctrl_file_path is malformed, last biblatex run probably failed. Deleted $output"); } - # Write ctrl file as UTF-8 - File::Slurper::write_text($ctrl_file_path, NFC($checkbuf));# Unicode NFC boundary # Validate if asked to if (Biber::Config->getoption('validate_control')) { ee506290e05a8f3869d143f'>refslogtreecommitdiff
path: root/gnu/build/linux-container.scm
AgeCommit message (Collapse)Author
2019-09-12linux-container: "run-container" scripts shows the container's PID.Ludovic Courtès
* gnu/build/linux-container.scm (call-with-container): Add #:process-spawned-hook and honor it. * gnu/system/linux-container.scm (container-script)[script]: Define 'explain' and pass it as #:process-spawned-hook'.
2019-07-06linux-container: Mount a new /dev/pts instance in the container.Ludovic Courtès
Fixes <https://bugs.gnu.org/36463>. Reported by Steffen Rytter Postas <nc@scalehost.eu>. * gnu/build/linux-container.scm (mount-file-systems): When /dev/ptmx exists on the host, explicitly mount a new instance of devpts and make /dev/ptmx a symlink to /dev/pts/ptmx.
2019-06-23linux-container: Remove dependency on (guix utils).Ludovic Courtès
Fixes a bug whereby derivations importing (gnu build linux-container), such as the 'bitlbee' and 'tor' services, would depend on the user's (guix config) file, which was pulled as a dependency of (guix utils). As a result, those derivations would vary from user to user. * gnu/build/linux-container.scm (call-with-temporary-directory): New procedure.
2019-04-02linux-container: Make the guest UID and GID a parameter.Ludovic Courtès
* gnu/build/linux-container.scm (initialize-user-namespace): Add #:guest-uid and #:guest-gid parameters and honor them. (run-container): Likewise. (call-with-container): Likewise. * tests/containers.scm ("call-with-container, user namespace, guest UID/GID"): New test.