Help CMake find Clang's libraries. Have it install the ICD file in the right place. diff --git a/CMake/FindLLVM.cmake b/CMake/FindLLVM.cmake index 5457f248..e8e8f94a 100644 --- a/CMake/FindLLVM.cmake +++ b/CMake/FindLLVM.cmake @@ -107,7 +107,7 @@ endif (LLVM_VERSION_NODOT VERSION_GREATER 34) macro(add_one_lib name) FIND_LIBRARY(CLANG_LIB NAMES ${name} - PATHS ${LLVM_LIBRARY_DIR} NO_DEFAULT_PATH) + PATHS ${CLANG_LIBRARY_DIR} NO_DEFAULT_PATH) set(CLANG_LIBRARIES ${CLANG_LIBRARIES} ${CLANG_LIB}) unset(CLANG_LIB CACHE) endmacro() diff --git a/CMakeLists.txt b/CMakeLists.txt index c11acbb2..fb99e5c8 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -217,7 +217,7 @@ IF(OCLIcd_FOUND) "intel-beignet.icd.in" "${ICD_FILE_NAME}" ) - install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${ICD_FILE_NAME} DESTINATION /etc/OpenCL/vendors) + install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${ICD_FILE_NAME} DESTINATION etc/OpenCL/vendors COMPONENT config) ELSE(OCLIcd_FOUND) MESSAGE(STATUS "Looking for OCL ICD header file - not found") MESSAGE(FATAL_ERROR "OCL ICD loader miss. If you really want to disable OCL ICD support, please run cmake with option -DOCLICD_COMPAT=0.") -- 2.14.3 ix/tree/gnu/tests/nfs.scm?id=ffffc0227a0c9b9d506cdb947469361f77afe8d6'>treecommitdiff
path: root/gnu/tests/nfs.scm
AgeCommit message (Expand)Author
2021-12-23tests: nfs: Fix nfs-root-fs test....Mathieu Othacehe
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-04-10tests: nfs: Fix typo in description....Tobias Geerinckx-Rice
2020-11-07tests: nfs-root-fs: Use the right store file name....Ludovic Courtès
2020-09-10tests: nfs: Improve "nfs-root-fs"....Danny Milosavljevic
2020-09-07tests: nfs: Improve "nfs-root-fs"....Danny Milosavljevic
2020-09-07tests: Add "nfs-root-fs" system test....Stefan
2020-03-25tests/nfs: Fix use of WAIT-FOR-FILE....Ricardo Wurmus
2020-03-16tests: nfs-server: Use marionette helper procedures....Ludovic Courtès
2020-03-16tests: nfs: Ensure 'rpcinfo' can be found....Ludovic Courtès
2020-01-08services: nfs: Add nfs-service-type....Ricardo Wurmus