Help CMake find Clang's libraries.
Have it install the ICD file in the right place.
diff --git a/CMake/FindLLVM.cmake b/CMake/FindLLVM.cmake
index 5457f248..e8e8f94a 100644
--- a/CMake/FindLLVM.cmake
+++ b/CMake/FindLLVM.cmake
@@ -107,7 +107,7 @@ endif (LLVM_VERSION_NODOT VERSION_GREATER 34)
macro(add_one_lib name)
FIND_LIBRARY(CLANG_LIB
NAMES ${name}
- PATHS ${LLVM_LIBRARY_DIR} NO_DEFAULT_PATH)
+ PATHS ${CLANG_LIBRARY_DIR} NO_DEFAULT_PATH)
set(CLANG_LIBRARIES ${CLANG_LIBRARIES} ${CLANG_LIB})
unset(CLANG_LIB CACHE)
endmacro()
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c11acbb2..fb99e5c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -217,7 +217,7 @@ IF(OCLIcd_FOUND)
"intel-beignet.icd.in"
"${ICD_FILE_NAME}"
)
- install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${ICD_FILE_NAME} DESTINATION /etc/OpenCL/vendors)
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${ICD_FILE_NAME} DESTINATION etc/OpenCL/vendors COMPONENT config)
ELSE(OCLIcd_FOUND)
MESSAGE(STATUS "Looking for OCL ICD header file - not found")
MESSAGE(FATAL_ERROR "OCL ICD loader miss. If you really want to disable OCL ICD support, please run cmake with option -DOCLICD_COMPAT=0.")
--
2.14.3
6d0773720b6a5c913'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2024-04-18 | news: Add entry for nss-certs being added to %base-packages....* etc/news.scm: New entry.
* NEWS: Update news.
Change-Id: I40e0b859f2af0bb0e652925a53d6447ea6fbacfb
| Maxim Cournoyer |
2023-03-28 | NEWS: Mention new rpm format....* NEWS (Package management): Mention new rpm format.
| Maxim Cournoyer |
2022-12-18 | Update NEWS. | Ludovic Courtès |
2022-12-17 | Update NEWS. | Marius Bakke |
2022-12-02 | Update NEWS. | Ludovic Courtès |
2022-11-23 | NEWS: Update it....* NEWS: Shepherd is already at 0.9.3 now.
| Jonathan Brielmaier |
2022-11-16 | Update NEWS. | Maxim Cournoyer |
2022-10-13 | NEWS: Update it....* NEWS: Add an entry about 'guix shell' --emulate-fhs option.
| Mathieu Othacehe |
2022-10-07 | Update NEWS....* NEWS: Add new entry for installation script improvements.
| Maxim Cournoyer |
2022-09-28 | Update NEWS....* NEWS: Add new services for the 1.4.0.
| Mathieu Othacehe |
2022-09-26 | NEWS: Update it....* NEWS: Add an entry about WSL images.
| Mathieu Othacehe |
2022-09-24 | Update NEWS. | Ludovic Courtès |
2022-09-23 | Update NEWS. | Maxim Cournoyer |
2022-09-19 | Update NEWS....* NEWS: Mention Shepherd 0.9.2 upgrade.
| Mathieu Othacehe |
2022-09-16 | Update NEWS....Entries extracted from:
git log 3eadcdc63..version-1.4.0
* NEWS: Update entries for v1.4.0
| Mathieu Othacehe |
2022-09-15 | Update NEWS....This covers the commits made between v1.3.0..3eadcdc6^.
* NEWS: New entries for the 1.4.0 upcoming release.
| Maxim Cournoyer |
2022-09-14 | Update NEWS....These news were extracted from the output of:
git log --reverse v1.3.0..03eb0b1be2cfedd0d9a66fef0edc53a17f7653a5.
* NEWS: Update entries for v1.4.0.
| Maxim Cournoyer |