From: Tobias Geerinckx-Rice Date: Wed, 3 Oct 2018 23:30:42 +0200 Subject: [PATCH] bastet: Change source of unordered_set. This allows building bastet 0.43.2 with boost >=1.66. It was backported verbatim from the upstream master branch. From 0e03f8d4d6bc6949cf1c447e632ce0d1b98c4be1 Mon Sep 17 00:00:00 2001 From: Federico Poloni Date: Wed, 4 Oct 2017 19:35:01 +0200 Subject: [PATCH] Changed source of unordered_set (should hopefully fix #6 without reopening #1) --- BastetBlockChooser.hpp | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/BastetBlockChooser.hpp b/BastetBlockChooser.hpp index 992e556..7ee3b7c 100644 --- a/BastetBlockChooser.hpp +++ b/BastetBlockChooser.hpp @@ -23,8 +23,7 @@ #include "Well.hpp" -#include -#include +#include #include namespace Bastet{ @@ -75,7 +74,7 @@ namespace Bastet{ public: Searcher(BlockType b, const Well *well, Vertex v, WellVisitor *visitor); private: - std::tr1::unordered_set _visited; + boost::unordered_set _visited; //std::set _visited; ^^ the above is more efficient, we need to do many inserts BlockType _block; const Well *_well; c9c14a9'>treecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-03-18 17:28:02 -0400
committerLeo Famulari <leo@famulari.name>2023-03-22 11:49:04 -0400
commit91f92f32d5a9317dd333d570b54c2ba34c9c14a9 (patch)
tree0e27712a29f2632bbbf0e01b9868bde9a15abce0 /ChangeLog
parent4f8a13b9fbfd0efcb94ee8da46b09c6dbe84ac4b (diff)
downloadguix-91f92f32d5a9317dd333d570b54c2ba34c9c14a9.tar.gz
guix-91f92f32d5a9317dd333d570b54c2ba34c9c14a9.zip
gnu: OpenSSH: Update to 9.3p1 [security fixes].
The release announcement contains more information about the security vulnerabilities fixed in this update: https://www.openssh.com/txt/release-9.3 * gnu/packages/ssh.scm (openssh): Update to 9.3p1.
Diffstat (limited to 'ChangeLog')