Bash-completion is written with FHS in mind where completion scripts all get added to /usr/share/bash-completion/completions and are picked up by the dynamic completion loader from there---whether they are part of bash-completion or installed by another package. On Guix systems, we want not only to search within bash-completion's own directory, but also in the user's profile and in the system profile. This is what this patch does. --- a/bash_completion 2016-08-03 10:23:02.356782287 +0200 +++ b/bash_completion 2016-08-03 10:27:50.120140403 +0200 @@ -1960,7 +1960,13 @@ __load_completion() { - local -a dirs=( ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions ) + local -a dirs=( + "$HOME/.guix-profile/share/bash-completion/completions/$base" + "$HOME/.guix-profile/etc/bash_completion.d/$base" + "/run/current-system/profile/share/bash-completion/completions/$base" + "/run/current-system/profile/etc/bash_completion.d/$base" + ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions ) + local OIFS=$IFS IFS=: dir cmd="$1" compfile for dir in ${XDG_DATA_DIRS:-/usr/local/share:/usr/share}; do dirs+=( $dir/bash-completion/completions ) cc08c14073dca0193e9238ca88e9e'>treecommitdiff
path: root/gnu/system/file-systems.scm
AgeCommit message (Expand)Author
2018-06-14install: Use (guix store database) instead of 'guix-register'....Ludovic Courtès
2018-05-28file-systems: Remove 'title' field and add <file-system-label>....Ludovic Courtès
2018-05-19file-systems: Do not export <file-system>....Ludovic Courtès
2018-04-29file-systems: Expound '%pseudo-file-system-types'....Ludovic Courtès
2018-04-27guix system: Report wrong file system 'device' fields....Ludovic Courtès
2017-12-22file-systems: Move %control-groups from %base-file-systems to...Mathieu Othacehe
2017-12-22file-systems: Do not mount hugetlb cgroup filesystem....Mathieu Othacehe
2017-10-11file-systems: Preserve UUID types when serializing....Ludovic Courtès
2017-10-05file-systems: Add a 'location' field to <file-system>....Ludovic Courtès
2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès
2017-09-11file-systems: Introduce (gnu system uuid)....Ludovic Courtès