Bash-completion is written with FHS in mind where completion scripts
all get added to /usr/share/bash-completion/completions and are picked
up by the dynamic completion loader from there---whether they are
part of bash-completion or installed by another package.
On Guix systems, we want not only to search within bash-completion's own
directory, but also in the user's profile and guix home profile, as well
as in the system profile.
This is what this patch does.
--- a/bash_completion
+++ b/bash_completion
@@ -2173,7 +2173,15 @@ complete -F _minimal ''
__load_completion()
{
- local -a dirs=(${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions)
+ local -a dirs=(
+ ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions
+ "$HOME/.guix-profile/share/bash-completion/completions"
+ "$HOME/.guix-profile/etc/bash_completion.d"
+ "$HOME/.guix-home/profile/share/bash-completion/completions"
+ "$HOME/.guix-home/profile/etc/bash_completion.d"
+ "/run/current-system/profile/share/bash-completion/completions"
+ "/run/current-system/profile/etc/bash_completion.d" )
+
local ifs=$IFS IFS=: dir cmd="${1##*/}" compfile
[[ -n $cmd ]] || return 1
for dir in ${XDG_DATA_DIRS:-/usr/local/share:/usr/share}; do
dirs+=( $dir/bash-completion/completions )
f='/guix/diff/gnu/packages/xiph.scm?id=461602d07c8da0e29bae392270f4ef3fd4f7fffb'>diff
|
Age | Commit message (Expand) | Author |
2023-04-14 | Merge branch 'master' into core-updates....Conflicts:
gnu/local.mk
gnu/packages/build-tools.scm
gnu/packages/certs.scm
gnu/packages/check.scm
gnu/packages/compression.scm
gnu/packages/cups.scm
gnu/packages/fontutils.scm
gnu/packages/gnuzilla.scm
gnu/packages/guile.scm
gnu/packages/ibus.scm
gnu/packages/image-processing.scm
gnu/packages/linux.scm
gnu/packages/music.scm
gnu/packages/nss.scm
gnu/packages/pdf.scm
gnu/packages/python-xyz.scm
gnu/packages/qt.scm
gnu/packages/ruby.scm
gnu/packages/shells.scm
gnu/packages/tex.scm
gnu/packages/video.scm
gnu/packages/vulkan.scm
gnu/packages/web.scm
gnu/packages/webkit.scm
gnu/packages/wm.scm
| Maxim Cournoyer |
2023-03-24 | gnu: speexdsp: Update to 1.2.1....* gnu/packages/xiph.scm (speexdsp): Update to 1.2.1.
| Maxim Cournoyer |
2023-02-07 | gnu: speex: Update to 1.2.1....* gnu/packages/xiph.scm (speex): Update to 1.2.1.
| Maxim Cournoyer |
2022-08-27 | Merge branch 'staging' into core-updates | Marius Bakke |
2022-08-14 | gnu: rnnoise: Remove input labels....* gnu/packages/xiph.scm (rnnoise)[native-inputs]:
Remove input labels.
| Tobias Geerinckx-Rice |
2022-08-14 | gnu: rnnoise: Unhide and rename variable....* gnu/packages/xiph.scm (xiph-rnnoise): Rename to…
(rnnoise): …this. Adjust all users.
[properties]: Remove HIDDEN? property as it is no longer ambiguous.
| Tobias Geerinckx-Rice |