This patch adds the "sigc" and "std" namespace prefixes where needed. It also replaces a double single-argument "bind" with a single two-argument "bind", because the former would confuse the compiler. The patch has been sent to the developer on 2016-09-26. --- azr3-jack-1.2.3/azr3/knob.cpp 2016-09-26 10:29:27.653375902 +0200 +++ azr3-jack-1.2.3/azr3/knob.cpp 2016-09-26 10:29:38.693430647 +0200 @@ -44,7 +44,7 @@ set_size_request(44, 44); add_events(EXPOSURE_MASK | BUTTON1_MOTION_MASK | BUTTON_PRESS_MASK | SCROLL_MASK); - m_adj.signal_value_changed().connect(mem_fun(*this, &Knob::queue_draw)); + m_adj.signal_value_changed().connect(sigc::mem_fun(*this, &Knob::queue_draw)); } --- azr3-jack-1.2.3/azr3/drawbar.cpp 2016-09-26 10:27:40.632845216 +0200 +++ azr3-jack-1.2.3/azr3/drawbar.cpp 2016-09-26 10:27:48.952886473 +0200 @@ -37,7 +37,7 @@ set_size_request(22, 150); add_events(EXPOSURE_MASK | BUTTON1_MOTION_MASK | BUTTON_PRESS_MASK | SCROLL_MASK); - m_adj.signal_value_changed().connect(mem_fun(*this, &Drawbar::queue_draw)); + m_adj.signal_value_changed().connect(sigc::mem_fun(*this, &Drawbar::queue_draw)); } --- azr3-jack-1.2.3/azr3/switch.cpp 2016-09-26 10:28:48.169180111 +0200 +++ azr3-jack-1.2.3/azr3/switch.cpp 2016-09-26 10:28:55.713217520 +0200 @@ -49,7 +49,7 @@ } set_size_request(m_width, m_height); add_events(EXPOSURE_MASK | BUTTON_PRESS_MASK | SCROLL_MASK); - m_adj.signal_value_changed().connect(mem_fun(*this, &Switch::queue_draw)); + m_adj.signal_value_changed().connect(sigc::mem_fun(*this, &Switch::queue_draw)); } --- azr3-jack-1.2.3/azr3/azr3gui.cpp 2016-09-26 09:05:10.106963561 +0200 +++ azr3-jack-1.2.3/azr3/azr3gui.cpp 2016-09-26 10:26:47.480581648 +0200 @@ -73,19 +73,19 @@ m_tbox = add_textbox(m_fbox, pixmap, 391, 19, 3, 140, 39); m_tbox->add_events(SCROLL_MASK); m_tbox->signal_scroll_display. - connect(mem_fun(*this, &AZR3GUI::d
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu system images novena)
  #:use-module (gnu bootloader)
  #:use-module (gnu bootloader u-boot)
  #:use-module (gnu image)
  #:use-module (gnu packages linux)
  #:use-module (guix platforms arm)
  #:use-module (gnu services)
  #:use-module (gnu services base)
  #:use-module (gnu system)
  #:use-module (gnu system file-systems)
  #:use-module (gnu system image)
  #:use-module (srfi srfi-26)
  #:export (novena-barebones-os
            novena-image-type
            novena-barebones-raw-image))

(define novena-barebones-os
  (operating-system
    (host-name "vignemale")
    (timezone "Europe/Paris")
    (locale "en_US.utf8")
    (bootloader (bootloader-configuration
                 (bootloader u-boot-novena-bootloader)
                 (targets '("/dev/vda"))))
    (initrd-modules '())
    (kernel linux-libre-arm-generic)
    (kernel-arguments '("console=ttymxc1,115200"))
    (file-systems (cons (file-system
                          (device (file-system-label "my-root"))
                          (mount-point "/")
                          (type "ext4"))
                        %base-file-systems))))

(define novena-image-type
  (image-type
   (name 'novena-raw)
   (constructor (lambda (os)
                  (image
                   (inherit (raw-with-offset-disk-image))
                   (operating-system os)
                   (platform armv7-linux))))))

(define novena-barebones-raw-image
  (image
   (inherit
    (os+platform->image novena-barebones-os armv7-linux
                        #:type novena-image-type))
   (name 'novena-barebones-raw-image)))

;; Return the default image.
novena-barebones-raw-image
size()) { sw->get_adjustment().signal_value_changed(). - connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed),port), - mem_fun(sw->get_adjustment(), &Adjustment::get_value))); + connect(compose(sigc::bind<0>(sigc::mem_fun(*this, &AZR3GUI::control_changed),port), + sigc::mem_fun(sw->get_adjustment(), &Adjustment::get_value))); assert(m_adj[port] == 0); m_adj[port] = &sw->get_adjustment(); } @@ -489,7 +489,7 @@ oss<first<<' '<second.substr(0, 23); MenuItem* item = manage(new MenuItem(oss.str())); item->signal_activate(). - connect(bind(mem_fun(*this, &AZR3GUI::program_changed), iter->first)); + connect(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::program_changed), iter->first)); m_program_menu->items().push_back(*item); item->show(); item->get_child()->modify_bg(STATE_NORMAL, m_menu_bg); @@ -503,8 +503,8 @@ for (int i = 0; i < 128; ++i) { MenuItem* item = manage(new MenuItem(note2str(i))); item->signal_activate(). - connect(bind(mem_fun(*m_splitpoint_adj, &Adjustment::set_value), - i / 128.0)); + connect(sigc::bind(sigc::mem_fun(*m_splitpoint_adj, &Adjustment::set_value), + i / 128.0)); m_split_menu->items().push_back(*item); item->show(); item->get_child()->modify_bg(STATE_NORMAL, m_menu_bg); @@ -533,7 +533,7 @@ MenuItem* save_item = manage(new MenuItem("Save program")); save_item->signal_activate(). - connect(mem_fun(*this, &AZR3GUI::save_program)); + connect(sigc::mem_fun(*this, &AZR3GUI::save_program)); save_item->show(); save_item->get_child()->modify_fg(STATE_NORMAL, m_menu_bg); save_item->get_child()->modify_fg(STATE_NORMAL, m_menu_fg);