Patch by Andreas Enge to force installation of libraries into lib
independently of the architecture, instead of lib32 or lib64.
On x86_64, the C library path coded in CMAKE_C_IMPLICIT_LINK_DIRECTORIES
contains a library (jack) installed into lib64, which forces lib64
for avidemux with the original code.
diff -u -r avidemux_2.6.8.orig/cmake/admInstallDir.cmake avidemux_2.6.8/cmake/admInstallDir.cmake
--- avidemux_2.6.8.orig/cmake/admInstallDir.cmake 2014-03-12 07:15:23.000000000 +0100
+++ avidemux_2.6.8/cmake/admInstallDir.cmake 2015-07-26 14:31:10.418459984 +0200
@@ -16,13 +16,7 @@
MESSAGE(STATUS "No install dir provided, using /usr/local")
ENDIF(NOT AVIDEMUX_INSTALL_DIR )
SET(AVIDEMUX_BIN_DIR ${AVIDEMUX_INSTALL_DIR}/bin)
- IF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
- SET(AVIDEMUX_RELATIVE_LIB_DIR lib64)
- ELSEIF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib32([; ]|$)")
- SET(AVIDEMUX_RELATIVE_LIB_DIR lib32)
- ELSE(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
- SET(AVIDEMUX_RELATIVE_LIB_DIR lib)
- ENDIF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
+ SET(AVIDEMUX_RELATIVE_LIB_DIR lib)
SET(AVIDEMUX_LIB_DIR ${AVIDEMUX_INSTALL_DIR}/${AVIDEMUX_RELATIVE_LIB_DIR})
ENDIF(WIN32)
SET(AVIDEMUX_INCLUDE_DIR ${AVIDEMUX_INSTALL_DIR}/include)
ix/diff/gnu/packages/gnunet.scm?id=101a4e2718db6b9b96333d75cacb761640074405'>diff
|
Age | Commit message (Expand) | Author |
2022-09-07 | gnunet-scheme: Unbundle config.rpath....* gnu/packages/gnunet.scm (gnunet-scheme)[origin]{snippet}: New snippet.
Signed-off-by: Marius Bakke <marius@gnu.org>
| Maxime Devos |
2022-09-07 | gnu: gnunet-scheme: Make scheme-gnunet.pdf reproducible....* gnu/packages/gnunet.scm
(gnunet-scheme)[arguments]<#:phases>{reproducible-timestamp}:
New phase.
Signed-off-by: Marius Bakke <marius@gnu.org>
| Maxime Devos |
2022-09-07 | gnu: gnunet-scheme: Update to 0.3....The old snippet doesn't apply anymore, so a different work-around was
committed to gnunet-scheme.
* gnu/packages/gnunet.scm (gnunet-scheme): Update to 0.3.
[description]: Update description for new features.
Signed-off-by: Marius Bakke <marius@gnu.org>
| Maxime Devos |
2022-05-29 | gnu: libmicrohttpd: Update to 0.9.75....* gnu/packages/gnunet.scm (libmicrohttpd): Update to 0.9.75.
| Tobias Geerinckx-Rice |
2022-05-29 | gnu: libmicrohttpd: Use G-expressions....* gnu/packages/gnunet.scm (libmicrohttpd)[arguments]:
Rewrite as G-expressions.
| Tobias Geerinckx-Rice |
2022-04-01 | gnu: gnunet: Update to 0.16.3....* gnu/packages/gnunet.scm (gnunet): Update to 0.16.3.
[arguments]: Enable all the tests that were disabled.
[inputs]: Use new style. [native-inputs]: Add openssl.
[home-page]: Update URL.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Tanguy Le Carrour |
2022-02-05 | gnu: Add gnunet-scheme....This is not the same as guile-gnunet, see the description.
* gnu/packages/gnunet.scm (gnunet-scheme): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Maxime Devos |