From: Antonio Larrosa Date: Fri, 10 Mar 2017 15:40:02 +0100 Subject: Fix signature of multiplyCheckOverflow. It returns a bool, not an int --- libaudiofile/modules/MSADPCM.cpp | 2 +- sfcommands/sfconvert.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/libaudiofile/modules/MSADPCM.cpp b/libaudiofile/modules/MSADPCM.cpp index ef9c38c..d8c9553 100644 --- a/libaudiofile/modules/MSADPCM.cpp +++ b/libaudiofile/modules/MSADPCM.cpp @@ -116,7 +116,7 @@ int firstBitSet(int x) #define __has_builtin(x) 0 #endif -int multiplyCheckOverflow(int a, int b, int *result) +bool multiplyCheckOverflow(int a, int b, int *result) { #if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow)) return __builtin_mul_overflow(a, b, result); diff --git a/sfcommands/sfconvert.c b/sfcommands/sfconvert.c index 970a3e4..367f7a5 100644 --- a/sfcommands/sfconvert.c +++ b/sfcommands/sfconvert.c @@ -60,7 +60,7 @@ int firstBitSet(int x) #define __has_builtin(x) 0 #endif -int multiplyCheckOverflow(int a, int b, int *result) +bool multiplyCheckOverflow(int a, int b, int *result) { #if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow)) return __builtin_mul_overflow(a, b, result); it/po/packages/es.po?id=1deaa74a6fbe07ae7052e7e8e97cd4618b04e6b3'>commitdiff
path: root/po/packages/es.po
AgeCommit message (Expand)Author
2023-05-31nls: Update translations....* doc/guix-cookbook.texi (Top): Mention Slovak. Florian Pelz
2023-03-07nls: Update translations.Julien Lepiller
2022-12-04nls: Update translations....po/packages/vi.po: New file. po/packages/LINGUAS: Add it. Julien Lepiller
2022-11-04nls: Update translations....* po/guix/lt.po: New file. * po/guix/LINGUAS: Add lt. Julien Lepiller
2022-10-06nls: Update translations.Julien Lepiller
2022-09-04nls: Update translations.Julien Lepiller
2022-08-10nls: Update translations....po/guix/bn.po: New file. po/guix/LINGUAS: Add it. Julien Lepiller
2022-07-09nls: Update translations....po/guix/tr.po: New file. po/guix/LINGUAS: Add it. Julien Lepiller
2022-06-04nls: Update translations....po/packages/tr.po: New file. po/packages/LINGUAS: Add it. Julien Lepiller
2022-05-01nls: Update translations....po/guix/ja.po: New file. po/guix/LINGUAS: Add it. Julien Lepiller