Based on (hunks for changelog and Identy.cpp removed) From ecbc07f0ed336187cc9a67c3363f89681b8b8f52 Mon Sep 17 00:00:00 2001 From: Michael Pruett Date: Tue, 5 Jul 2016 23:26:16 -0500 Subject: [PATCH] Fix type of test data arrays. --- ChangeLog | 6 ++++++ test/Identify.cpp | 3 ++- test/NeXT.cpp | 7 ++++--- 3 files changed, 12 insertions(+), 4 deletions(-) diff --git a/test/NeXT.cpp b/test/NeXT.cpp index 7e39850..29af877 100644 --- a/test/NeXT.cpp +++ b/test/NeXT.cpp @@ -30,6 +30,7 @@ #include #include #include +#include #include #include #include @@ -37,7 +38,7 @@ #include "TestUtilities.h" -const char kDataUnspecifiedLength[] = +const uint8_t kDataUnspecifiedLength[] = { '.', 's', 'n', 'd', 0, 0, 0, 24, // offset of 24 bytes @@ -57,7 +58,7 @@ const char kDataUnspecifiedLength[] = 0, 55 }; -const char kDataTruncated[] = +const uint8_t kDataTruncated[] = { '.', 's', 'n', 'd', 0, 0, 0, 24, // offset of 24 bytes @@ -152,7 +153,7 @@ TEST(NeXT, Truncated) ASSERT_EQ(::unlink(testFileName.c_str()), 0); } -const char kDataZeroChannels[] = +const uint8_t kDataZeroChannels[] = { '.', 's', 'n', 'd', 0, 0, 0, 24, // offset of 24 bytes 4e0b9d475d805'>treecommitdiff
...* gnu/packages/parallel.scm (parallel): Update to 20200422.
AgeCommit message (Collapse)Author
2021-06-26etc: snippets: Use ‘hg-file-name’ when origin uses ‘hg-fetch’Xinglu Chen
Adjust to changes in commit aaafd19bd1e37265de07e246286a6819792c25b4. * etc/snippets/scheme-mode/guix-origin: Use ‘hg-file-name’ instead of ‘string-append’ when ‘method’ for origin is ‘hg-fetch’. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2020-12-23etc: snippets: Add new build systems to package snippet.Morgan Smith
* etc/snippets/scheme-mode/guix-package: Add the following as possibilities for the build-system field: clojure-build-system copy-build-system dune-build-system guile-build-system julia-build-system linux-module-build-system maven-build-system node-build-system qt-build-system rakudo-build-system Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2020-12-04etc: snippets: Fix name extraction.Nicolas Goaziou
* etc/snippets/text-mode/guix-commit-message-add-package: Fix name extraction. This is a follow-up to 988a49c78ef19ad25cef543e2059a19db04bbd36.
2020-12-04etc: snippets: Fix name extraction.Nicolas Goaziou
* etc/snippets/text-mode/guix-commit-message-update-package: Since git commit mode is not derived from any Lisp mode, so-called sexp or symbols do not include the period character. As a consequence, names including versions are not properly extracted. Also use more idiomatic (goto-char (point-min)) instead of (beginning-of-buffer).
2020-11-25etc: snippets: Fix "gnu: Add ..." name when prefilling Common Lisp commits ↵Pierre Neidhardt
messages. * etc/snippets/text-mode/guix-commit-message-add-cl-package: Fix name and simplify the "New variables" line.
2020-11-23etc: snippets: Prefill Common Lisp package names.Pierre Neidhardt
* etc/snippets/text-mode/guix-commit-message-add-cl-package: New file.
2020-11-23etc: snippets: Fix package name extraction.Pierre Neidhardt
* etc/snippets/text-mode/guix-commit-message-add-package: Properly extract name when the diff contains a very short `define-public ...` above the actual new package. This can happen when the above package is a small inherited definition or cl/ecl package.
Efraim Flashner