From: Antonio Larrosa Date: Thu, 9 Mar 2017 10:21:18 +0100 Subject: Check for division by zero in BlockCodec::runPull --- libaudiofile/modules/BlockCodec.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libaudiofile/modules/BlockCodec.cpp b/libaudiofile/modules/BlockCodec.cpp index 4731be1..eb2fb4d 100644 --- a/libaudiofile/modules/BlockCodec.cpp +++ b/libaudiofile/modules/BlockCodec.cpp @@ -47,7 +47,7 @@ void BlockCodec::runPull() // Read the compressed data. ssize_t bytesRead = read(m_inChunk->buffer, m_bytesPerPacket * blockCount); - int blocksRead = bytesRead >= 0 ? bytesRead / m_bytesPerPacket : 0; + int blocksRead = (bytesRead >= 0 && m_bytesPerPacket > 0) ? bytesRead / m_bytesPerPacket : 0; // Decompress into m_outChunk. for (int i=0; i Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2023-09-28gnu: Add pantheon-terminal....altadil
2023-09-28gnu: Add granite-6....altadil
2023-09-05gnu: sideload: Update to 6.2.1....Maxim Cournoyer
2023-09-05gnu: pantheon-calculator: Update to 2.0.2....altadil
2023-09-05gnu: granite: Upgrade to 7.3.0....altadil
2023-07-08gnu: pantheon-wallpapers: Use a source file-name....Efraim Flashner
2023-07-01gnu: Add pantheon-wallpapers....Wamm K. D
2022-04-05gnu: pantheon-calculator: Update to 1.7.2....jgart