From: Antonio Larrosa Date: Thu, 9 Mar 2017 10:21:18 +0100 Subject: Check for division by zero in BlockCodec::runPull --- libaudiofile/modules/BlockCodec.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libaudiofile/modules/BlockCodec.cpp b/libaudiofile/modules/BlockCodec.cpp index 4731be1..eb2fb4d 100644 --- a/libaudiofile/modules/BlockCodec.cpp +++ b/libaudiofile/modules/BlockCodec.cpp @@ -47,7 +47,7 @@ void BlockCodec::runPull() // Read the compressed data. ssize_t bytesRead = read(m_inChunk->buffer, m_bytesPerPacket * blockCount); - int blocksRead = bytesRead >= 0 ? bytesRead / m_bytesPerPacket : 0; + int blocksRead = (bytesRead >= 0 && m_bytesPerPacket > 0) ? bytesRead / m_bytesPerPacket : 0; // Decompress into m_outChunk. for (int i=0; i Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/README
AgeCommit message (Collapse)Author
2021-05-20The #guix channel is hosted by Libera Chat.Tobias Geerinckx-Rice
* README (Contact): Update network name. * ROADMAP: Likewise. * doc/contributing.texi (Contributing): Likewise. * doc/guix.texi (After System Installation): Likewise.
2020-10-23doc: Update README.Maxim Cournoyer
* README (Installation): Do not mention installing Guix from Git anymore. (Building from Git): Add section.
2020-10-22README: Refer to the manual for building from Git.Maxim Cournoyer
* README (Installing Guix from Guix): Remove section. (Installation): For installing from Git, refer to the "Building from Git" section of the manual and suggest using './pre-inst-env guix pull' rather than 'make install' for installing Guix.
2020-06-02doc: Update README to refer to the manual.Ludovic Courtès
* README (Requirements): Refer to the manual. (Installation): Update URL of the manual.
2019-11-09doc: Mention value /var to localstatedir option.zimoun
* README (Installing Guix from Guix): Mention value /var to localstatedir option. * doc/contributing.texi (Building from Git): Likewise. * doc/guix.texi (Requirements): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>