From: Antonio Larrosa Date: Mon, 6 Mar 2017 12:51:22 +0100 Subject: Always check the number of coefficients When building the library with NDEBUG, asserts are eliminated so it's better to always check that the number of coefficients is inside the array range. This fixes the 00191-audiofile-indexoob issue in #41 --- libaudiofile/WAVE.cpp | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/libaudiofile/WAVE.cpp b/libaudiofile/WAVE.cpp index 9dd8511..0fc48e8 100644 --- a/libaudiofile/WAVE.cpp +++ b/libaudiofile/WAVE.cpp @@ -281,6 +281,12 @@ status WAVEFile::parseFormat(const Tag &id, uint32_t size) /* numCoefficients should be at least 7. */ assert(numCoefficients >= 7 && numCoefficients <= 255); + if (numCoefficients < 7 || numCoefficients > 255) + { + _af_error(AF_BAD_HEADER, + "Bad number of coefficients"); + return AF_FAIL; + } m_msadpcmNumCoefficients = numCoefficients;
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
AgeCommit message (Expand)Author
2019-01-25gnu: python-rdflib: Use PYPI-URI....Ricardo Wurmus
2019-01-16gnu: Move dbm databases to new module....Ricardo Wurmus
2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus
2018-12-21gnu: python-rdflib: Update to 4.2.2....Pjotr Prins
2018-11-11gnu: lrdf: Replace bootstrap phase....Ricardo Wurmus
2018-11-11gnu: lrdf: Fetch sources from git....Ricardo Wurmus
2018-08-15gnu: serd: Update to 0.30.0....Tobias Geerinckx-Rice
2018-08-10gnu: sord: Update to 0.16.2....Tobias Geerinckx-Rice
2018-06-22gnu: Use HTTPS for drobilla.net URIs....Tobias Geerinckx-Rice
2018-04-12Merge branch 'master' into core-updatesMark H Weaver
2018-04-12gnu: lrdf: Update to 0.6.1....Marius Bakke
2018-04-12gnu: sord: Return #t from all phases....Mark H Weaver
2018-04-12gnu: serd: Return #t from all phases....Mark H Weaver