From: Antonio Larrosa Date: Mon, 6 Mar 2017 12:51:22 +0100 Subject: Always check the number of coefficients When building the library with NDEBUG, asserts are eliminated so it's better to always check that the number of coefficients is inside the array range. This fixes the 00191-audiofile-indexoob issue in #41 --- libaudiofile/WAVE.cpp | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/libaudiofile/WAVE.cpp b/libaudiofile/WAVE.cpp index 9dd8511..0fc48e8 100644 --- a/libaudiofile/WAVE.cpp +++ b/libaudiofile/WAVE.cpp @@ -281,6 +281,12 @@ status WAVEFile::parseFormat(const Tag &id, uint32_t size) /* numCoefficients should be at least 7. */ assert(numCoefficients >= 7 && numCoefficients <= 255); + if (numCoefficients < 7 || numCoefficients > 255) + { + _af_error(AF_BAD_HEADER, + "Bad number of coefficients"); + return AF_FAIL; + } m_msadpcmNumCoefficients = numCoefficients; able class='tabs'> aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
AgeCommit message (Expand)Author
2024-06-03build: Use the po4a command for the translation generation....gemmaro
2024-06-03build: Update the POT creation task with the po4a command....gemmaro
2024-05-25configure.ac: Set default value for the 'prefix' variable....Maxim Cournoyer
2024-04-19maint: Resurrect running `make' from a tarball....Janneke Nieuwenhuizen
2023-10-22teams: Adjust shebang to use 'guix repl'....Maxim Cournoyer
2023-09-26build: Add dependency on Git....Ludovic Courtès
2022-07-03etc: Add teams.scm....Ricardo Wurmus
2022-01-25build: Require Guile >= 3.0.3....Ludovic Courtès
2021-11-23maint: "make dist" builds tarballs in 'ustar' format....Ludovic Courtès