From: Antonio Larrosa Date: Mon, 6 Mar 2017 12:51:22 +0100 Subject: Always check the number of coefficients When building the library with NDEBUG, asserts are eliminated so it's better to always check that the number of coefficients is inside the array range. This fixes the 00191-audiofile-indexoob issue in #41 --- libaudiofile/WAVE.cpp | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/libaudiofile/WAVE.cpp b/libaudiofile/WAVE.cpp index 9dd8511..0fc48e8 100644 --- a/libaudiofile/WAVE.cpp +++ b/libaudiofile/WAVE.cpp @@ -281,6 +281,12 @@ status WAVEFile::parseFormat(const Tag &id, uint32_t size) /* numCoefficients should be at least 7. */ assert(numCoefficients >= 7 && numCoefficients <= 255); + if (numCoefficients < 7 || numCoefficients > 255) + { + _af_error(AF_BAD_HEADER, + "Bad number of coefficients"); + return AF_FAIL; + } m_msadpcmNumCoefficients = numCoefficients; ='tabs'> aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
AgeCommit message (Expand)Author
2020-03-05tests: Add a manifest for system tests....Ludovic Courtès
2020-02-21build-system: Add copy-build-system....Pierre Neidhardt
2020-01-31gnu: Add earlyoom-service-type....Maxim Cournoyer
2019-12-27Add 'build-aux/git-authenticate.scm'....Ludovic Courtès
2019-12-18gnu: linux-libre: Update to 5.4.5....Mark H Weaver
2019-12-18gnu: linux-libre: Remove orphaned 5.2.x kernel configurations....Mark H Weaver
2019-12-01guix: Add the 'qt' build system....Hartmut Goebel
2019-11-15Add 'guix time-machine'....Konrad Hinsen
2019-10-23cve: Rewrite to read the JSON feed instead of the XML feed....Ludovic Courtès
2019-10-06Merge branch 'master' into core-updatesRicardo Wurmus
2019-10-01gnu: linux-libre: Add version 5.3.1....Tobias Geerinckx-Rice