From 822b732fd31ffcb78f6920001e9b1fbd815fa712 Mon Sep 17 00:00:00 2001 From: Wim Taymans Date: Thu, 27 Sep 2018 12:11:12 +0200 Subject: [PATCH] SimpleModule: set output chunk framecount after pull After pulling the data, set the output chunk to the amount of frames we pulled so that the next module in the chain has the correct frame count. Fixes #50 and #51 --- libaudiofile/modules/SimpleModule.cpp | 1 + 1 file changed, 1 insertion(+) diff --git a/libaudiofile/modules/SimpleModule.cpp b/libaudiofile/modules/SimpleModule.cpp index 2bae1eb..e87932c 100644 --- a/libaudiofile/modules/SimpleModule.cpp +++ b/libaudiofile/modules/SimpleModule.cpp @@ -26,6 +26,7 @@ void SimpleModule::runPull() { pull(m_outChunk->frameCount); + m_outChunk->frameCount = m_inChunk->frameCount; run(*m_inChunk, *m_outChunk); } type='submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/hackage.scm
AgeCommit message (Expand)Author
2022-06-06import: hackage: Filter upper/mixed case dependencies too....Lars-Dominik Braun
2022-06-06import: hackage: Filter internal libraries from inputs and native-inputs....Lars-Dominik Braun
2022-06-06import: cabal: Support library names...Lars-Dominik Braun
2022-06-06import: cabal: Document failing syntax through tests....Lars-Dominik Braun
2022-06-06import: cabal: Allow curly bracket before else statement....Lars-Dominik Braun
2022-06-06import: cabal: Allow properties without space between key and value....Lars-Dominik Braun
2022-06-06import: cabal: Allow curly brackets in more positions....Lars-Dominik Braun
2022-06-06import: cabal: Support elif statement....Lars-Dominik Braun
2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus
2021-12-01build-system: haskell: Add ‘hackage-uri’ procedure....Xinglu Chen
2021-09-17Merge branch 'master' into core-updates-frozen...Marius Bakke
2021-09-15import: cabal: Treat identifier names correctly....Xinglu Chen
2021-07-20import: hackage: Emit new-style package inputs....Sarah Morgensen
2021-06-25import: hackage: Support "common" field and imports...Philip Munksgaard
2021-05-22import: hackage: Prefix licenses with 'license:'....Xinglu Chen