From 822b732fd31ffcb78f6920001e9b1fbd815fa712 Mon Sep 17 00:00:00 2001 From: Wim Taymans Date: Thu, 27 Sep 2018 12:11:12 +0200 Subject: [PATCH] SimpleModule: set output chunk framecount after pull After pulling the data, set the output chunk to the amount of frames we pulled so that the next module in the chain has the correct frame count. Fixes #50 and #51 --- libaudiofile/modules/SimpleModule.cpp | 1 + 1 file changed, 1 insertion(+) diff --git a/libaudiofile/modules/SimpleModule.cpp b/libaudiofile/modules/SimpleModule.cpp index 2bae1eb..e87932c 100644 --- a/libaudiofile/modules/SimpleModule.cpp +++ b/libaudiofile/modules/SimpleModule.cpp @@ -26,6 +26,7 @@ void SimpleModule::runPull() { pull(m_outChunk->frameCount); + m_outChunk->frameCount = m_inChunk->frameCount; run(*m_inChunk, *m_outChunk); } submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/services
AgeCommit message (Expand)Author
2022-08-28services: Add lightdm-service-type....Maxim Cournoyer
2022-08-25services: configuration: Change the value of the unset marker....Attila Lendvai
2022-08-25services: Use the new maybe/unset API....Attila Lendvai
2022-08-09tests: configuration: Add a test to cover 'unset regression....Maxim Cournoyer
2022-08-01services: configuration: Step back from *unspecified*....Maxim Cournoyer
2022-07-07tests: telephony: Remove obsolete parsing tests....Maxim Cournoyer
2022-06-24services: configuration: Report the location of field type errors....Ludovic Courtès
2022-06-15services: configuration: Use *unspecified* instead of 'disabled....Attila Lendvai
2022-06-15services: configuration: Support (field1 maybe-number "") format....Attila Lendvai