From 822b732fd31ffcb78f6920001e9b1fbd815fa712 Mon Sep 17 00:00:00 2001 From: Wim Taymans Date: Thu, 27 Sep 2018 12:11:12 +0200 Subject: [PATCH] SimpleModule: set output chunk framecount after pull After pulling the data, set the output chunk to the amount of frames we pulled so that the next module in the chain has the correct frame count. Fixes #50 and #51 --- libaudiofile/modules/SimpleModule.cpp | 1 + 1 file changed, 1 insertion(+) diff --git a/libaudiofile/modules/SimpleModule.cpp b/libaudiofile/modules/SimpleModule.cpp index 2bae1eb..e87932c 100644 --- a/libaudiofile/modules/SimpleModule.cpp +++ b/libaudiofile/modules/SimpleModule.cpp @@ -26,6 +26,7 @@ void SimpleModule::runPull() { pull(m_outChunk->frameCount); + m_outChunk->frameCount = m_inChunk->frameCount; run(*m_inChunk, *m_outChunk); } n> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader/extlinux.scm
AgeCommit message (Expand)Author
2018-05-12bootloader: extlinux: Fix menu support with u-boot....Vagrant Cascadian
2017-12-15bootloader: Factorize write-file-on-device....Mathieu Othacehe
2017-12-04bootloader: extlinux: Stop using dd binary....Mathieu Othacehe
2017-11-23bootloader: extlinux: Fix device tree path....Mathieu Othacehe
2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic
2017-06-21bootloader: extlinux: Add extlinux-bootloader-gpt....Mathieu Othacehe
2017-06-08bootloader: Use menu-entry to define custom bootloader entries....Mathieu Othacehe
2017-05-21bootloader: extlinux: Add a warning message on top of generated conf file....Mathieu Othacehe
2017-05-18bootloader: extlinux: Remove syslinux-bootloader....Mathieu Othacehe
2017-05-18bootloader: extlinux: Remove undefined symbols from export list....Mathieu Othacehe
2017-05-16bootloader: Add extlinux support....Mathieu Othacehe