From 822b732fd31ffcb78f6920001e9b1fbd815fa712 Mon Sep 17 00:00:00 2001 From: Wim Taymans Date: Thu, 27 Sep 2018 12:11:12 +0200 Subject: [PATCH] SimpleModule: set output chunk framecount after pull After pulling the data, set the output chunk to the amount of frames we pulled so that the next module in the chain has the correct frame count. Fixes #50 and #51 --- libaudiofile/modules/SimpleModule.cpp | 1 + 1 file changed, 1 insertion(+) diff --git a/libaudiofile/modules/SimpleModule.cpp b/libaudiofile/modules/SimpleModule.cpp index 2bae1eb..e87932c 100644 --- a/libaudiofile/modules/SimpleModule.cpp +++ b/libaudiofile/modules/SimpleModule.cpp @@ -26,6 +26,7 @@ void SimpleModule::runPull() { pull(m_outChunk->frameCount); + m_outChunk->frameCount = m_inChunk->frameCount; run(*m_inChunk, *m_outChunk); } it' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix/libstore
AgeCommit message (Expand)Author
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2024-01-05daemon: Change default ‘timeout’ and ‘max-silent-time’ values....Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2023-09-26daemon: Add “git-download” built-in builder....Ludovic Courtès
2023-09-09daemon: Fix build with GCC 13....Sören Tempel