Fix build with gfortran 10. Taken from Debian: https://salsa.debian.org/science-team/atlas/-/blob/master/debian/patches/gfortran-10.patch --- a/interfaces/blas/C/testing/c_dblat1.f +++ b/interfaces/blas/C/testing/c_dblat1.f @@ -247,11 +247,11 @@ IF (ICASE.EQ.7) THEN * .. DNRM2TEST .. STEMP(1) = DTRUE1(NP1) - CALL STEST1(DNRM2TEST(N,SX,INCX),STEMP,STEMP,SFAC) + CALL STEST1(DNRM2TEST(N,SX,INCX),STEMP(1),STEMP,SFAC) ELSE IF (ICASE.EQ.8) THEN * .. DASUMTEST .. STEMP(1) = DTRUE3(NP1) - CALL STEST1(DASUMTEST(N,SX,INCX),STEMP,STEMP,SFAC) + CALL STEST1(DASUMTEST(N,SX,INCX),STEMP(1),STEMP,SFAC) ELSE IF (ICASE.EQ.9) THEN * .. DSCALTEST .. CALL DSCALTEST(N,SA((INCX-1)*5+NP1),SX,INCX) --- a/interfaces/blas/C/testing/c_sblat1.f +++ b/interfaces/blas/C/testing/c_sblat1.f @@ -247,11 +247,11 @@ IF (ICASE.EQ.7) THEN * .. SNRM2TEST .. STEMP(1) = DTRUE1(NP1) - CALL STEST1(SNRM2TEST(N,SX,INCX),STEMP,STEMP,SFAC) + CALL STEST1(SNRM2TEST(N,SX,INCX),STEMP(1),STEMP,SFAC) ELSE IF (ICASE.EQ.8) THEN * .. SASUMTEST .. STEMP(1) = DTRUE3(NP1) - CALL STEST1(SASUMTEST(N,SX,INCX),STEMP,STEMP,SFAC) + CALL STEST1(SASUMTEST(N,SX,INCX),STEMP(1),STEMP,SFAC) ELSE IF (ICASE.EQ.9) THEN * .. SSCALTEST .. CALL SSCALTEST(N,SA((INCX-1)*5+NP1),SX,INCX) 4d9be0d1856b'/>
path: root/.gitignore
AgeCommit message (Expand)Author
2019-09-24Merge branch 'master' into core-updatesLudovic Courtès
2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus
2019-06-14build: Remove 'gnu/packages/bootstrap' and its binaries....Ludovic Courtès
2019-04-26bootstrap: Break automake dependency on generated files....Miguel Ángel Arruga Vivas
2018-11-20.gitignore: Re-add 'authenticate' script....Marius Bakke
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-12.gitignore: Add doc/stamp-[0-9].Ludovic Courtès
2018-04-19gnu: doc: Allow documentation to be translated....Julien Lepiller
2018-02-13.gitignore: Add guix-daemon SELinux policy....Efraim Flashner
2017-05-13.gitignore: Ignore Emacs auto-save files....ng0
2017-05-08build: Add doc/guix.html to .gitignore....Clément Lassieur
2017-05-04build: Use Gnulib's 'git-version-gen'....Ludovic Courtès
2017-02-27.gitignore: Remove stale entries....Alex Kost
2017-02-10build: Add build-aux/ar-lib to .gitignore....Clément Lassieur
2017-01-13etc: Support indentation of whole files....Ludovic Courtès
2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès
2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel
2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès