--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100
+++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100
@@ -90,16 +90,22 @@
rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p);
APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv);
+ /* /etc/services is not available while compiling, so apr_getservbyname
+ * will always return APR_ENOENT. */
+#if 0
rv = apr_getservbyname(sa, "ftp");
APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv);
ABTS_INT_EQUAL(tc, 21, sa->port);
+#endif
rv = apr_getservbyname(sa, "complete_and_utter_rubbish");
APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv);
+#if 0
rv = apr_getservbyname(sa, "telnet");
APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv);
ABTS_INT_EQUAL(tc, 23, sa->port);
+#endif
}
static apr_socket_t *setup_socket(abts_case *tc)
>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-08-24 | services: unattended-upgrade: Log output of the 'guix' commands....Fixes <https://bugs.gnu.org/43011>.
Reported by Jesse Gibbons <jgibbons2357@gmail.com>.
Until now the stdout/stderr file descriptors were not redirected.
* gnu/services/admin.scm (unattended-upgrade-mcron-jobs)[code]: Remove
'with-logging' and use 'redirect-port' instead.
| Ludovic Courtès |
2020-08-24 | services: unattended-upgrade: Add 'operating-system-file' field....* gnu/services/admin.scm (<unattended-upgrade-configuration>)[operating-system-file]:
New field.
(unattended-upgrade-mcron-jobs): Honor it.
* doc/guix.texi (Unattended Upgrades): Document it.
| Ludovic Courtès |
2020-07-27 | services: Add 'unattended-upgrade-service-type'....* gnu/services/admin.scm (<unattended-upgrade-configuration>): New
record type.
(%unattended-upgrade-log-file): New variable.
(unattended-upgrade-mcron-jobs, unattended-upgrade-log-rotations): New
procedures.
(unattended-upgrade-service-type): New variable.
* doc/guix.texi (Service Reference): Add 'provenance-service-type' anchor.
(Unattended Upgrades): New section.
| Ludovic Courtès |
2020-05-06 | services: rottlog: Append '.gz' to rotated file....Fixes <https://issues.guix.info/issue/40945>.
* gnu/services/admin.scm (%default-rotations): Add option 'storefile'.
| Brice Waegeneire |