--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100
+++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100
@@ -90,16 +90,22 @@
rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p);
APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv);
+ /* /etc/services is not available while compiling, so apr_getservbyname
+ * will always return APR_ENOENT. */
+#if 0
rv = apr_getservbyname(sa, "ftp");
APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv);
ABTS_INT_EQUAL(tc, 21, sa->port);
+#endif
rv = apr_getservbyname(sa, "complete_and_utter_rubbish");
APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv);
+#if 0
rv = apr_getservbyname(sa, "telnet");
APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv);
ABTS_INT_EQUAL(tc, 23, sa->port);
+#endif
}
static apr_socket_t *setup_socket(abts_case *tc)
sub'>Wojtek's customized Guix
|
Age | Commit message (Expand) | Author |
2024-04-01 | nls: Update translations....* po/guix/ar.po: New file.
* po/guix/LINGUAS: Add 'ar'.
* po/doc/guix-cookbook.pt_BR.po: New file.
* po/doc/local.mk: Add 'pt_BR' cookbook.
* doc/local.mk: Add 'pt_BR' cookbook.
* doc/htmlxref.cnf: Update URLs for cookbook.
* doc/build.scm (%cookbook-languages): Add 'ko', 'pt_BR'.
* doc/guix-cookbook.texi (Top): Mention 'ko', 'pt_BR' cookbook.
Change-Id: Id1846ca100263b3fc1fa2ed52654c670270ee809
| Florian Pelz |
2022-12-18 | doc: Update URLs for the manual and cookbook translations....* doc/htmlxref.cnf: Update URLs for "guix" and "guix-cookbook".
| Ludovic Courtès |
2022-12-18 | doc: Add guile-netlink to 'htmlxref.cnf'....* doc/htmlxref.cnf: Add guile-netlink.
| Ludovic Courtès |
2022-08-05 | doc: Fix Guix manual URLs in 'htmlxref.cnf'....Fixes a regression introduced in
868da34d54365023223a4ff7520043ba55ad64e8.
* doc/htmlxref.cnf (GUIX): Remove "/guix".
| Ludovic Courtès |
2022-06-16 | doc: Remove obsolete comment from htmlxref.cnf....This is follow up to <https://issues.guix.gnu.org/55290>.
* doc/htmlxref.cnf (geiser): Delete obsolete comment.
| Maxim Cournoyer |