--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100 +++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100 @@ -90,16 +90,22 @@ rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p); APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv); + /* /etc/services is not available while compiling, so apr_getservbyname + * will always return APR_ENOENT. */ +#if 0 rv = apr_getservbyname(sa, "ftp"); APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv); ABTS_INT_EQUAL(tc, 21, sa->port); +#endif rv = apr_getservbyname(sa, "complete_and_utter_rubbish"); APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv); +#if 0 rv = apr_getservbyname(sa, "telnet"); APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv); ABTS_INT_EQUAL(tc, 23, sa->port); +#endif } static apr_socket_t *setup_socket(abts_case *tc) >Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/pack.scm
AgeCommit message (Expand)Author
2023-03-17Revert "tests: pack: Fix indentation."...Maxim Cournoyer
2023-02-27pack: Make sure tests can run without a world rebuild....Ludovic Courtès
2023-02-19pack: Add RPM format....Maxim Cournoyer
2023-02-19tests: pack: Fix indentation....Maxim Cournoyer
2022-10-22Remove now unnecessary uses of (guix grafts)....Ludovic Courtès
2021-07-18Merge branch 'master' into core-updatesLudovic Courtès
2021-07-18pack: Allow embedding custom control files in deb packs....Maxim Cournoyer
2021-07-11pack: Adjust test to earlier <compressor> changes....Ludovic Courtès
2021-06-29pack: Add support for the deb format....Maxim Cournoyer
2021-06-29tests: pack: Fix compressor extension....Maxim Cournoyer