--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100
+++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100
@@ -90,16 +90,22 @@
rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p);
APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv);
+ /* /etc/services is not available while compiling, so apr_getservbyname
+ * will always return APR_ENOENT. */
+#if 0
rv = apr_getservbyname(sa, "ftp");
APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv);
ABTS_INT_EQUAL(tc, 21, sa->port);
+#endif
rv = apr_getservbyname(sa, "complete_and_utter_rubbish");
APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv);
+#if 0
rv = apr_getservbyname(sa, "telnet");
APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv);
ABTS_INT_EQUAL(tc, 23, sa->port);
+#endif
}
static apr_socket_t *setup_socket(abts_case *tc)
orm>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2019-03-13 | doc: Document the graphical installer some more....* doc/guix.texi (Preparing for Installation): Rewrite to specify the two
installation modes.
(Guided Graphical Installation): New node.
(Manual Installation): New node, with the former sections.
(After System Installation): New node.
* doc/images/installer-network.png, doc/images/installer-partitions.png,
doc/images/installer-resume.png: New files.
* doc/local.mk (dist_infoimage_DATA): Add them.
| Ludovic Courtès |