--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100 +++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100 @@ -90,16 +90,22 @@ rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p); APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv); + /* /etc/services is not available while compiling, so apr_getservbyname + * will always return APR_ENOENT. */ +#if 0 rv = apr_getservbyname(sa, "ftp"); APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv); ABTS_INT_EQUAL(tc, 21, sa->port); +#endif rv = apr_getservbyname(sa, "complete_and_utter_rubbish"); APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv); +#if 0 rv = apr_getservbyname(sa, "telnet"); APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv); ABTS_INT_EQUAL(tc, 23, sa->port); +#endif } static apr_socket_t *setup_socket(abts_case *tc) class='sub'>Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/nfs.scm
AgeCommit message (Expand)Author
2021-12-23services: nfs: Fix statd and mountd ports....Mathieu Othacehe
2021-02-05gnu: services: Fix the NFS service....Maxim Cournoyer
2020-05-29services: nfs: Expose configuration options for TCP and UDP....Maxim Cournoyer
2020-03-27services/nfs: Replace nfs-version with nfs-versions....Ricardo Wurmus
2020-03-25services/nfs: Mount nfsd pseudo file system....Ricardo Wurmus
2020-03-16services: nfs: Remove unnecessary "mount" invocation....Ludovic Courtès
2020-03-16services: nfs: Move activation snippet out of line....Ludovic Courtès
2020-03-08services: nfs: Run rpc.mountd in foreground....Maxim Cournoyer
2020-01-08services: nfs: Add nfs-service-type....Ricardo Wurmus
2020-01-08services: nfs: Allow gss-service-type to be extended....Ricardo Wurmus
2020-01-08services: nfs: Add verbosity control to idmap-service-type....Ricardo Wurmus
2020-01-08services: nfs: Allow idmap-service-type to be extended....Ricardo Wurmus
2020-01-08services: nfs: Fix indentation and typo....Ricardo Wurmus
2020-01-08services: nfs: Allow pipefs-service-type to be extended....Ricardo Wurmus
2020-01-08services: nfs: Allow rpcbind-service-type to be extended....Ricardo Wurmus
2020-01-08services: nfs: Fix name of package variable....Ricardo Wurmus