--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100 +++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100 @@ -90,16 +90,22 @@ rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p); APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv); + /* /etc/services is not available while compiling, so apr_getservbyname + * will always return APR_ENOENT. */ +#if 0 rv = apr_getservbyname(sa, "ftp"); APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv); ABTS_INT_EQUAL(tc, 21, sa->port); +#endif rv = apr_getservbyname(sa, "complete_and_utter_rubbish"); APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv); +#if 0 rv = apr_getservbyname(sa, "telnet"); APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv); ABTS_INT_EQUAL(tc, 23, sa->port); +#endif } static apr_socket_t *setup_socket(abts_case *tc) x
aboutsummaryrefslogtreecommitdiff
path: root/m4
AgeCommit message (Expand)Author
2022-01-14gnu: bootstrap: Add support for riscv64-linux....Efraim Flashner
2021-12-14build: Adjust 'courage level' of different systems....Efraim Flashner
2021-05-23gnu: bootstrap: Add support for powerpc-linux....Efraim Flashner
2021-03-23Add powerpc64le-linux as a supported Guix architecture....Chris Marusich
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-09-08Remove (guix json) and require Guile-JSON 4.3.0+....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun
2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-02-22build: Depend on guile-ssh 0.12.0...Lars-Dominik Braun
2019-08-17build: 'GUIX_CHECK_GUILE_JSON' really checks for Guile-JSON 3.x....Ludovic Courtès
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt