--- test/testsock.c 2013-01-24 06:57:21.000000000 +0100
+++ test/testsock.c 2013-01-24 17:24:54.000000000 +0100
@@ -90,16 +90,22 @@
rv = apr_sockaddr_info_get(&sa, NULL, APR_UNSPEC, 0, 0, p);
APR_ASSERT_SUCCESS(tc, "Problem generating sockaddr", rv);
+ /* /etc/services is not available while compiling, so apr_getservbyname
+ * will always return APR_ENOENT. */
+#if 0
rv = apr_getservbyname(sa, "ftp");
APR_ASSERT_SUCCESS(tc, "Problem getting ftp service", rv);
ABTS_INT_EQUAL(tc, 21, sa->port);
+#endif
rv = apr_getservbyname(sa, "complete_and_utter_rubbish");
APR_ASSERT_SUCCESS(tc, "Problem getting non-existent service", !rv);
+#if 0
rv = apr_getservbyname(sa, "telnet");
APR_ASSERT_SUCCESS(tc, "Problem getting telnet service", rv);
ABTS_INT_EQUAL(tc, 23, sa->port);
+#endif
}
static apr_socket_t *setup_socket(abts_case *tc)
td class='sub'>Wojtek's customized Guix
|
Age | Commit message (Expand) | Author |
2020-12-15 | serialization: 'restore-file' sets canonical timestamp and permissions....* guix/serialization.scm (restore-file): Set the permissions and mtime
of FILE.
* guix/nar.scm (finalize-store-file): Pass #:reset-timestamps? #f to
'register-items'.
* tests/nar.scm (rm-rf): Add 'chmod' calls to ensure files are writable.
("write-file + restore-file with symlinks"): Ensure every file in OUTPUT
passes 'canonical-file?'.
* tests/guix-archive.sh: Run "chmod -R +w" before "rm -rf".
| Ludovic Courtès |
2020-09-28 | tests: Simplify shell exit status negation;...* tests/guix-archive.sh, tests/guix-build-branch.sh, tests/guix-build.sh,
tests/guix-daemon.sh, tests/guix-download.sh, tests/guix-environment.sh,
tests/guix-gc.sh, tests/guix-git-authenticate.sh, tests/guix-graph.sh,
tests/guix-hash.sh, tests/guix-lint.sh, tests/guix-pack-relocatable.sh,
tests/guix-pack.sh, tests/guix-package-aliases.sh, tests/guix-package-net.sh,
tests/guix-package.sh: Use the shell '!' keyword to negate command exit status
in place of 'if ...; then false; else true; fi'
| Eric Bavier |
2019-12-12 | guix archive: Add '--list'....* guix/scripts/archive.scm (show-help, %options): Add '--list'.
(list-contents): New procedure.
(guix-archive): Honor the '--list' option.
* tests/guix-archive.sh: Test it.
* doc/guix.texi (Invoking guix archive): Document it.
| Ludovic Courtès |