Based on the upstream fix for the java8 compilation issue. Simplified patch. Upstream version of patch does not work with this source tree. The issue is that in java8 it is an error to pass null to removeAll. Results in null pointer exception. java7 behaviour was to return the list unmodified. From 43867d50c05d1c06ab7220eb974a8874ae10c308 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= Date: Fri, 5 Jan 2018 19:08:24 +0100 Subject: [PATCH] Fix java8 complilation error. --- tool/src/main/java/org/antlr/tool/CompositeGrammar.java | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/tool/src/main/java/org/antlr/tool/CompositeGrammar.java b/tool/src/main/java/org/antlr/tool/CompositeGrammar.java index f34ea73..63740a6 100644 --- a/tool/src/main/java/org/antlr/tool/CompositeGrammar.java +++ b/tool/src/main/java/org/antlr/tool/CompositeGrammar.java @@ -226,7 +226,9 @@ public class CompositeGrammar { public List getIndirectDelegates(Grammar g) { List direct = getDirectDelegates(g); List delegates = getDelegates(g); - delegates.removeAll(direct); + if(direct != null) { + delegates.removeAll(direct); + } return delegates; } -- 2.15.1 9a21f2cb46bfadd7de03e3'>treecommitdiff
AgeCommit message (Expand)Author
2020-12-28.guix-authorizations: Add leoprikler....* .guix-authorizations: Add leoprikler to the committers. Ludovic Courtès
2020-11-15.guix-authorizations: Add jonsger....* .guix-authorizations: Add jonsger to the committers. Marius Bakke
2020-10-16.guix-authorizations: Add m1gu3l....* .guix-authorizations: Add m1gu3l to the committers. Ludovic Courtès
2020-09-04.guix-authorizations: Add planglois to the committers....* .guix-authorizations: Add planglois. Ludovic Courtès
2020-07-18.guix-authorizations: Add brettgilio (back) to the committers....* .guix-authorizations: Add fingerprint for brettgilio. Tobias Geerinckx-Rice
2020-07-01.guix-authorizations: Remove keys of two former contributors....* .guix-authorizations: Remove key of David Craven, who left the project in 2017, and Federico Beffa, whose last commit was in Feb. 2017. Ludovic Courtès
2020-07-01.guix-authorizations: Remove former keys that are no longer used....* .guix-authorizations: Remove old keys of dvc, efraim, and janneke. Ludovic Courtès
2020-07-01.guix-authorizations: Remove brettgilio's old key....* .guix-authorizations: Remove key "DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE" (Brett Gilio). See <https://lists.gnu.org/archive/html/guix-devel/2020-06/msg00323.html>. Ludovic Courtès
2020-05-04.guix-authorizations: Add bricewge to the committers....* .guix-authorizations: Add fingerprint for bricewge. Ludovic Courtès
2020-05-04.guix-authorizations: Augment....* .guix-authorizations: Add all the currently authorized committers. Ludovic Courtès
2020-05-04Add '.guix-authorizations'....* .guix-authorizations: New file. Ludovic Courtès