Based on the upstream fix for the java8 compilation issue. Simplified patch. Upstream version of patch does not work with this source tree. The issue is that in java8 it is an error to pass null to removeAll. Results in null pointer exception. java7 behaviour was to return the list unmodified. From 43867d50c05d1c06ab7220eb974a8874ae10c308 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= Date: Fri, 5 Jan 2018 19:08:24 +0100 Subject: [PATCH] Fix java8 complilation error. --- tool/src/main/java/org/antlr/tool/CompositeGrammar.java | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/tool/src/main/java/org/antlr/tool/CompositeGrammar.java b/tool/src/main/java/org/antlr/tool/CompositeGrammar.java index f34ea73..63740a6 100644 --- a/tool/src/main/java/org/antlr/tool/CompositeGrammar.java +++ b/tool/src/main/java/org/antlr/tool/CompositeGrammar.java @@ -226,7 +226,9 @@ public class CompositeGrammar { public List getIndirectDelegates(Grammar g) { List direct = getDirectDelegates(g); List delegates = getDelegates(g); - delegates.removeAll(direct); + if(direct != null) { + delegates.removeAll(direct); + } return delegates; } -- 2.15.1 a5cd802568c20888c5a8b1a017f5'>commitdiff
path: root/m4
AgeCommit message (Expand)Author
2021-03-23Add powerpc64le-linux as a supported Guix architecture....Chris Marusich
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-09-08Remove (guix json) and require Guile-JSON 4.3.0+....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun
2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-02-22build: Depend on guile-ssh 0.12.0...Lars-Dominik Braun
2019-08-17build: 'GUIX_CHECK_GUILE_JSON' really checks for Guile-JSON 3.x....Ludovic Courtès
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt