Based on the upstream fix for the java8 compilation issue. Simplified patch. Upstream version of patch does not work with this source tree. The issue is that in java8 it is an error to pass null to removeAll. Results in null pointer exception. java7 behaviour was to return the list unmodified. From db2a350c6d90efaa8dde949fa76005c2c5af45c4 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= Date: Fri, 5 Jan 2018 17:05:31 +0100 Subject: [PATCH] Fix java8 compilation. --- src/org/antlr/tool/CompositeGrammar.java | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/src/org/antlr/tool/CompositeGrammar.java b/src/org/antlr/tool/CompositeGrammar.java index f1408e7..7e02431 100644 --- a/src/org/antlr/tool/CompositeGrammar.java +++ b/src/org/antlr/tool/CompositeGrammar.java @@ -218,7 +218,9 @@ public class CompositeGrammar { public List getIndirectDelegates(Grammar g) { List direct = getDirectDelegates(g); List delegates = getDelegates(g); - delegates.removeAll(direct); + if (direct != null) { + delegates.removeAll(direct); + } return delegates; } -- 2.15.1 x/tree/HACKING?id=b4f04e0efff1fb6112b84dc6d36ea46215c336b2'>treecommitdiff
AgeCommit message (Expand)Author
2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual....* HACKING (Commit Access): Remove. (Contributing): Update URL of the manual. * doc/contributing.texi (Commit Access): New section. (Submitting Patches): Add cross reference. Ludovic Courtès
2020-01-09doc: Add "Tracking Bugs and Patches" section....* doc/contributing.texi (Tracking Bugs and Patches): New section. (Submitting Patches): Refer to it. * doc/guix.texi: Update copyright line. * HACKING (Using emacs-debbugs): Remove. Ludovic Courtès
2019-07-13doc: Update keyserver URL....* HACKING (Commit Access): Change keyserver URL to 'keys.openpgp.org'. Leo Famulari
2019-02-11HACKING: Update key server....* HACKING (Commit Access): Recommend pool.sks-keyservers.net. Ludovic Courtès
2018-07-22doc: Fix typo (missing period)...* HACKING (Commit Access): Fix typo. Pierre Neidhardt
2017-08-19doc: Mention how to use emacs-debbugs....* HACKING (Using emacs-debbugs): Add section on using emacs-debbugs. Arun Isaac
2017-03-27maint: Give command to install the pre-push hook....* HACKING: Add 'cp' line to install the pre-push hook. Ludovic Courtès
2017-03-24maint: Mention the Signed-off-by line in 'HACKING'....* HACKING: Mention the Signed-off-by line. Clément Lassieur
2017-03-15maint: Mention guix-patches@gnu.org in 'HACKING'....Fixes <http://bugs.gnu.org/25899>. * HACKING: Mention guix-patches@gnu.org. Ludovic Courtès
2017-01-30maint: Fix invalid calls to 'info'....* HACKING <Contributing>: Remove name of the manual from the item argument. * README <Installation>: Likewise. Mathieu Lirzin