Based on the upstream fix for the java8 compilation issue. Simplified patch. Upstream version of patch does not work with this source tree. The issue is that in java8 it is an error to pass null to removeAll. Results in null pointer exception. java7 behaviour was to return the list unmodified. From db2a350c6d90efaa8dde949fa76005c2c5af45c4 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?G=C3=A1bor=20Boskovits?= Date: Fri, 5 Jan 2018 17:05:31 +0100 Subject: [PATCH] Fix java8 compilation. --- src/org/antlr/tool/CompositeGrammar.java | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/src/org/antlr/tool/CompositeGrammar.java b/src/org/antlr/tool/CompositeGrammar.java index f1408e7..7e02431 100644 --- a/src/org/antlr/tool/CompositeGrammar.java +++ b/src/org/antlr/tool/CompositeGrammar.java @@ -218,7 +218,9 @@ public class CompositeGrammar { public List getIndirectDelegates(Grammar g) { List direct = getDirectDelegates(g); List delegates = getDelegates(g); - delegates.removeAll(direct); + if (direct != null) { + delegates.removeAll(direct); + } return delegates; } -- 2.15.1 nu/packages/grub.scm'>logtreecommitdiff
AgeCommit message (Expand)Author
2016-10-05gnu: grub: Make dependency on mdadm explicit....Ludovic Courtès
2016-09-06gnu: Fix pre-2.7.0 qemu builds....Efraim Flashner
2016-08-30gnu: grub: Use https URL....ng0
2016-07-13gnu: grub: Update to 2.02~beta3....Jan Nieuwenhuizen
2016-05-23gnu: grub: Re-enable test....Leo Famulari
2016-05-17lint: Honor 'cpe-name' and 'cpe-version' package properties....Ludovic Courtès
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2015-12-21gnu: grub: Add fix for CVE-2015-8730....Leo Famulari
2015-11-21gnu: Add qemu-minimal....Ludovic Courtès
2015-10-28gnu: grub: Install documentation....Mark H Weaver
2015-10-28gnu: grub: Use modify-phases and other minor cleanups....Mark H Weaver
2015-03-06gnu: grub: Add patch to fix new version of freetype...Tomáš Čech
2014-11-08gnu: grub: Add dependency on GNU Unifont....Ludovic Courtès
2014-10-26gnu: Some cleanup based on lint checkers....Eric Bavier
2014-09-13gnu: Synchronize GNU package descriptions with upstream....Ludovic Courtès
2014-04-06gnu: Synchronize synopses and descriptions with the Womb....Ludovic Courtès