Description: Add check for buffer overflow with malformed input files This was later re-found and became CVE-2014-8123. Author: Bug-Debian: http://bugs.debian.org/407015 Bug-Debian: https://bugs.debian.org/771768 Forwarded: http://seclists.org/oss-sec/2014/q4/870 Last-Update: 2016-01-11 --- antiword-0.37~/wordole.c 2005-08-26 21:49:57.000000000 +0200 +++ antiword-0.37/wordole.c 2009-06-03 22:31:15.948014682 +0200 @@ -259,6 +259,10 @@ } tNameSize = (size_t)usGetWord(0x40, aucBytes); tNameSize = (tNameSize + 1) / 2; + if ( tNameSize > sizeof(atPPSlist[iIndex].szName)) { + werr(0, "Name Size of PPS %d is too large", iIndex); + tNameSize = sizeof(atPPSlist[iIndex].szName); + } vName2String(atPPSlist[iIndex].szName, aucBytes, tNameSize); atPPSlist[iIndex].ucType = ucGetByte(0x42, aucBytes); if (atPPSlist[iIndex].ucType == 5) { > Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/local.mk
AgeCommit message (Expand)Author
2024-08-31gnu: libstdc++-doc: Build libstdc++ info documentation....Bruno Victal
2024-08-31gnu: secilc: Drop xmlto workaround....Bruno Victal
2024-08-31gnu: dblatex: Fix missing texlive binaries and fig2dev....Bruno Victal
2024-08-31gnu: docbook2x: Import patches from debian....Bruno Victal
2024-08-31gnu: docbook-utils: Import patches from debian....Bruno Victal
2024-08-31gnu: docbook: Remove leftovers....Bruno Victal
2024-08-28home: services: Add home-beets-service-type....Fabio Natali
2024-08-28gnu: libgit2@1.8: Fix use of uninitialized value....Ludovic Courtès
2024-08-26gnu: cl-s-sysdeps: Add support for bordeaux-threads-2....Guillaume Le Vaillant
2024-08-22gnu: openscad: Fix build....Guillaume Le Vaillant
2024-08-22gnu: gpsbabel: Update to 1.9.0....Sergey Trofimov
2024-08-19gnu: isync: Update to 1.5.0....John Kehayias
2024-08-18gnu: icu4c: Add patch for VTIMEZONE bug....Jonathan Brielmaier
2024-08-11system: Add (gnu system privilege)....Tobias Geerinckx-Rice