Description: Add check for buffer overflow with malformed input files This was later re-found and became CVE-2014-8123. Author: Bug-Debian: http://bugs.debian.org/407015 Bug-Debian: https://bugs.debian.org/771768 Forwarded: http://seclists.org/oss-sec/2014/q4/870 Last-Update: 2016-01-11 --- antiword-0.37~/wordole.c 2005-08-26 21:49:57.000000000 +0200 +++ antiword-0.37/wordole.c 2009-06-03 22:31:15.948014682 +0200 @@ -259,6 +259,10 @@ } tNameSize = (size_t)usGetWord(0x40, aucBytes); tNameSize = (tNameSize + 1) / 2; + if ( tNameSize > sizeof(atPPSlist[iIndex].szName)) { + werr(0, "Name Size of PPS %d is too large", iIndex); + tNameSize = sizeof(atPPSlist[iIndex].szName); + } vName2String(atPPSlist[iIndex].szName, aucBytes, tNameSize); atPPSlist[iIndex].ucType = ucGetByte(0x42, aucBytes); if (atPPSlist[iIndex].ucType == 5) { ch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
AgeCommit message (Expand)Author
2019-12-10gnu: tor: Update to 0.4.2.5....* gnu/packages/tor.scm (tor): Update to 0.4.2.5. Tobias Geerinckx-Rice
2019-10-15gnu: onionshare: Update to 2.2....* gnu/packages/tor.scm (onionshare): Update to 2.2. [inputs]: Add python-flask-httpauth. [arguments]: Adjust 'fix-install-path' to new file name. [description]: Improve wording and clarity. [license]: Add expat license for bundled jquery. Eric Bavier
2019-09-19gnu: tor: Update to 0.4.1.6....* gnu/packages/tor.scm (tor): Update to 0.4.1.6. Tobias Geerinckx-Rice
2019-08-20gnu: tor: Update to 0.4.1.5....* gnu/packages/tor.scm (tor): Update to 0.4.1.5. Tobias Geerinckx-Rice
2019-08-13gnu: onionshare: Upgrade to 2.1....* gnu/packages/tor.scm (onionshare): Upgrade to 2.1. [arguments]: Rename "tests" phase to "check". Set home directory for tests. Remove reference to closed upstream bug. [inputs]: Add python-pycrypto and python-pysocks. [license]: Remove bsd-3 license; relevant file no longer present. Eric Bavier
2019-07-22gnu: zstd: Move libraries to separate outputs....* gnu/packages/compression.scm (zstd)[outputs]: New field. [arguments]: Add phase 'adjust-libary-locations'. Pass LIBDIR and INCLUDEDIR in <#:make-flags>. * gnu/packages/backup.scm (borg)[inputs]: Change ZSTD to ZSTD:LIB. * gnu/packages/sync.scm (casync)[inputs]: Likewise. * gnu/packages/tor.scm (tor)[inputs]: Likewise. * gnu/packages/linux.scm (btrfs-progs)[inputs]: Likewise. Add ZSTD:STATIC. Marius Bakke
2019-05-05gnu: tor: Remove explicit hardening flags....* gnu/packages/tor.scm (tor)[arguments]: Remove #:configure-flags that merely confirm the defaults. Tobias Geerinckx-Rice
2019-05-03gnu: tor: Update to 0.4.0.5....* gnu/packages/tor.scm (tor): Update to 0.4.0.5. Tobias Geerinckx-Rice