Description: Add check for buffer overflow with malformed input files This was later re-found and became CVE-2014-8123. Author: Bug-Debian: http://bugs.debian.org/407015 Bug-Debian: https://bugs.debian.org/771768 Forwarded: http://seclists.org/oss-sec/2014/q4/870 Last-Update: 2016-01-11 --- antiword-0.37~/wordole.c 2005-08-26 21:49:57.000000000 +0200 +++ antiword-0.37/wordole.c 2009-06-03 22:31:15.948014682 +0200 @@ -259,6 +259,10 @@ } tNameSize = (size_t)usGetWord(0x40, aucBytes); tNameSize = (tNameSize + 1) / 2; + if ( tNameSize > sizeof(atPPSlist[iIndex].szName)) { + werr(0, "Name Size of PPS %d is too large", iIndex); + tNameSize = sizeof(atPPSlist[iIndex].szName); + } vName2String(atPPSlist[iIndex].szName, aucBytes, tNameSize); atPPSlist[iIndex].ucType = ucGetByte(0x42, aucBytes); if (atPPSlist[iIndex].ucType == 5) { orm> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services.scm
AgeCommit message (Expand)Author
2023-03-16services: etc-service: Deprecate etc-service procedure....Bruno Victal
2022-08-30services: provenance: Use 'current-channels' to obtain provenance data....Ludovic Courtès
2022-05-29gnu: services: Update setuid service description....Tobias Geerinckx-Rice
2022-05-18services: Make <service-type> 'description' field mandatory....Ludovic Courtès
2022-05-18services: Add more description fields....Ludovic Courtès
2022-03-10services: startup: Add description....Ludovic Courtès
2021-11-27services: Document the 'delete' clause of 'modify-services'....Ludovic Courtès
2021-08-12system: Handle 'setuid-programs' deprecation handling as a field sanitizer....Ludovic Courtès
2021-07-29services: setuid: More configurable setuid support....Chris Lemmer-Webber
2021-05-11gnu: Allow services to install kernel-loadable modules....raid5atemyhomework
2021-04-12services: Support DELETE in MODIFY-SERVICES macro....Ricardo Wurmus