Modified from upstream commit:
https://github.com/ankitects/anki/commit/ccd715013609133c55e83924734efa78abc03326
Fixes mpv argument syntax (support for old syntax removed in mpv 0.31):
https://anki.tenderapp.com/discussions/ankidesktop/38186-mpvprocesserror-unable-to-start-process
Necessary because we are currently unable to upgrade anki to the
latest version in guix (NPM dependencies currently unpackaged).
---
anki/mpv.py | 4 ++--
anki/sound.py | 1 -
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/anki/mpv.py b/anki/mpv.py
index f53d9d0..563fddc 100644
--- a/anki/mpv.py
+++ b/anki/mpv.py
@@ -104,9 +104,9 @@ class MPVBase:
"""
self.argv = [self.executable]
self.argv += self.default_argv
- self.argv += ["--input-ipc-server", self._sock_filename]
+ self.argv += ["--input-ipc-server="+self._sock_filename]
if self.window_id is not None:
- self.argv += ["--wid", str(self.window_id)]
+ self.argv += ["--wid="+str(self.window_id)]
def _start_process(self):
"""Start the mpv process.
diff --git a/anki/sound.py b/anki/sound.py
index aa3431b..a5fce44 100644
--- a/anki/sound.py
+++ b/anki/sound.py
@@ -124,7 +124,6 @@ class MpvManager(MPV):
def setMpvConfigBase(base):
mpvConfPath = os.path.join(base, "mpv.conf")
MpvManager.default_argv += [
- "--no-config",
"--include="+mpvConfPath,
]
--
2.25.1
a>diff
|
Age | Commit message (Expand) | Author |
2024-01-28 | gnu: Add cl-qvm....* gnu/packages/quantum.scm (cl-qvm, sbcl-qvm): New variables.
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Change-Id: I1958fedab600df490f99961648cca49367ea29a6
| Michal Atlas |
2024-01-28 | gnu: Add cl-quil....* gnu/packages/quantum.scm (cl-quil, sbcl-cl-quil): New variables.
Change-Id: I7777f569cbb28737d25dd1e990a8e8aeb2c251b7
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
| Michal Atlas |
2024-01-28 | gnu: Add cl-rpcq....* gnu/packages/quantum.scm: New file.
(cl-rpcq, sbcl-rpcq): New variables.
* gnu/local.mk (GNU_SYSTEM_MODULES): Register "quantum.scm".
Change-Id: Ic893ad22ffb7a3bf9aa5e841fcf4c14bf3a23b2f
Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
| Michal Atlas |