Modified from upstream commit:
https://github.com/ankitects/anki/commit/ccd715013609133c55e83924734efa78abc03326
Fixes mpv argument syntax (support for old syntax removed in mpv 0.31):
https://anki.tenderapp.com/discussions/ankidesktop/38186-mpvprocesserror-unable-to-start-process
Necessary because we are currently unable to upgrade anki to the
latest version in guix (NPM dependencies currently unpackaged).
---
anki/mpv.py | 4 ++--
anki/sound.py | 1 -
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/anki/mpv.py b/anki/mpv.py
index f53d9d0..563fddc 100644
--- a/anki/mpv.py
+++ b/anki/mpv.py
@@ -104,9 +104,9 @@ class MPVBase:
"""
self.argv = [self.executable]
self.argv += self.default_argv
- self.argv += ["--input-ipc-server", self._sock_filename]
+ self.argv += ["--input-ipc-server="+self._sock_filename]
if self.window_id is not None:
- self.argv += ["--wid", str(self.window_id)]
+ self.argv += ["--wid="+str(self.window_id)]
def _start_process(self):
"""Start the mpv process.
diff --git a/anki/sound.py b/anki/sound.py
index aa3431b..a5fce44 100644
--- a/anki/sound.py
+++ b/anki/sound.py
@@ -124,7 +124,6 @@ class MpvManager(MPV):
def setMpvConfigBase(base):
mpvConfPath = os.path.join(base, "mpv.conf")
MpvManager.default_argv += [
- "--no-config",
"--include="+mpvConfPath,
]
--
2.25.1
href='/guix/diff/gnu/packages/bdw-gc.scm?id=26709726a80de2d22ab129ff49b38dc1600bf8b2'>diff
|
Age | Commit message (Expand) | Author |
2023-03-30 | gnu: libgc: Fix building on powerpc-linux....* gnu/pakcages/bdw-gc.scm (libgc)[arguments]: When building for
powerpc-linux add a make-flag to not protect virtual-dirty bits.
| Efraim Flashner |
2023-03-30 | gnu: libgc: Fix building on powerpc64le-linux....* gnu/packages/bdw-gc.scm (libgc)[arguments]: Add a make-flag when
building for powerpc64le-linux to disable using SDB (soft-dirty bits).
| Efraim Flashner |
2023-03-02 | gnu: libgc: Update to 8.2.2 and remove '--disable-munmap'....* gnu/packages/bdw-gc.scm (libgc): Update to 8.2.2.
[arguments]: Remove "--disable-munmap" from #:configure-flags.
* gnu/packages/guile.scm (guile-3.0)[source]: Leave 'test-out-of-memory'
test untouched.
(guile-next)[arguments]: Likewise, in 'skip-failing-tests' phase.
(guile-for-guile-emacs)[arguments]: Likewise, in 'bootstrap' phase.
| Ludovic Courtès |
2023-03-02 | Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts:
gnu/local.mk
gnu/packages/autotools.scm
gnu/packages/cmake.scm
gnu/packages/gnuzilla.scm
gnu/packages/haskell.scm
gnu/packages/pdf.scm
gnu/packages/python-xyz.scm
gnu/packages/samba.scm
gnu/packages/tex.scm
gnu/packages/tls.scm
gnu/packages/wxwidgets.scm
| Christopher Baines |
2023-02-25 | gnu: libgc: Define properties for the 'generic-html' updater....* gnu/packages/bdw-gc.scm (libgc)[source]: Add second URL.
[properties]: New field.
| Ludovic Courtès |