Modified from upstream commit: https://github.com/ankitects/anki/commit/ccd715013609133c55e83924734efa78abc03326 Fixes mpv argument syntax (support for old syntax removed in mpv 0.31): https://anki.tenderapp.com/discussions/ankidesktop/38186-mpvprocesserror-unable-to-start-process Necessary because we are currently unable to upgrade anki to the latest version in guix (NPM dependencies currently unpackaged). --- anki/mpv.py | 4 ++-- anki/sound.py | 1 - 2 files changed, 2 insertions(+), 3 deletions(-) diff --git a/anki/mpv.py b/anki/mpv.py index f53d9d0..563fddc 100644 --- a/anki/mpv.py +++ b/anki/mpv.py @@ -104,9 +104,9 @@ class MPVBase: """ self.argv = [self.executable] self.argv += self.default_argv - self.argv += ["--input-ipc-server", self._sock_filename] + self.argv += ["--input-ipc-server="+self._sock_filename] if self.window_id is not None: - self.argv += ["--wid", str(self.window_id)] + self.argv += ["--wid="+str(self.window_id)] def _start_process(self): """Start the mpv process. diff --git a/anki/sound.py b/anki/sound.py index aa3431b..a5fce44 100644 --- a/anki/sound.py +++ b/anki/sound.py @@ -124,7 +124,6 @@ class MpvManager(MPV): def setMpvConfigBase(base): mpvConfPath = os.path.join(base, "mpv.conf") MpvManager.default_argv += [ - "--no-config", "--include="+mpvConfPath, ] -- 2.25.1 81499373b262da40208525a9'>diff
path: root/gnu/image.scm
AgeCommit message (Expand)Author
2024-01-08scripts: system: Build layered images....Oleg Pykhalov
2022-09-24system: image: Add wsl2 support....Alex Griffin
2022-09-24system: image: Add tarball support....Alex Griffin
2022-09-24image: Make the operating-system field mandatory....Mathieu Othacehe
2022-09-07image: Use #true and #false....Mathieu Othacehe
2022-09-07image: Use a default size partition value....Mathieu Othacehe
2022-08-31image: Add comments....Mathieu Othacehe
2022-08-30image: Remove an unused field....Mathieu Othacehe
2022-08-30image: Perform more sanitizing....Mathieu Othacehe
2022-07-01image: Add sanitizers for 'format' and 'partition-table-type'....Ludovic Courtès
2022-07-01image: Add default value for partition initializer....Ludovic Courtès
2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/....Josselin Poiret