From d1d1368c7909ffd8423730afaa811ce7b6a3a8aa Mon Sep 17 00:00:00 2001 From: Tommy Jerry Mairo Date: Sun, 4 Feb 2018 12:42:00 -0800 Subject: [PATCH 1/2] Bugfix: API mismatch with crypto++ 6.0.0 --- src/ClientCreditsList.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/ClientCreditsList.cpp b/src/ClientCreditsList.cpp index 3bea9fe2d..a7ae1e34c 100644 --- a/src/ClientCreditsList.cpp +++ b/src/ClientCreditsList.cpp @@ -312,7 +312,7 @@ void CClientCreditsList::InitalizeCrypting() // calculate and store public key CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast(m_pSignkey)); CryptoPP::ArraySink asink(m_abyMyPublicKey, 80); - pubkey.DEREncode(asink); + pubkey.AccessMaterial().Save(asink); m_nMyPublicKeyLen = asink.TotalPutLength(); asink.MessageEnd(); } catch (const CryptoPP::Exception& e) { From 88ba0ac952b78382445f2fff73c6792c0474dc62 Mon Sep 17 00:00:00 2001 From: Tommy Jerry Mairo Date: Wed, 21 Mar 2018 11:56:28 -0700 Subject: [PATCH 2/2] Update: Change AccessMaterial to GetMaterial --- src/ClientCreditsList.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/ClientCreditsList.cpp b/src/ClientCreditsList.cpp index a7ae1e34c..69e881fd8 100644 --- a/src/ClientCreditsList.cpp +++ b/src/ClientCreditsList.cpp @@ -312,7 +312,7 @@ void CClientCreditsList::InitalizeCrypting() // calculate and store public key CryptoPP::RSASSA_PKCS1v15_SHA_Verifier pubkey(*static_cast(m_pSignkey)); CryptoPP::ArraySink asink(m_abyMyPublicKey, 80); - pubkey.AccessMaterial().Save(asink); + pubkey.GetMaterial().Save(asink); m_nMyPublicKeyLen = asink.TotalPutLength(); asink.MessageEnd(); } catch (const CryptoPP::Exception& e) {
AgeCommit message (Expand)Author
2020-10-23doc: Fix typo in HACKING....Maxim Cournoyer
2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual....Ludovic Courtès
2020-01-09doc: Add "Tracking Bugs and Patches" section....Ludovic Courtès
2019-07-13doc: Update keyserver URL....Leo Famulari
2019-02-11HACKING: Update key server....Ludovic Courtès
2018-07-22doc: Fix typo (missing period)...Pierre Neidhardt
2017-08-19doc: Mention how to use emacs-debbugs....Arun Isaac
2017-03-27maint: Give command to install the pre-push hook....Ludovic Courtès
2017-03-24maint: Mention the Signed-off-by line in 'HACKING'....Clément Lassieur
2017-03-15maint: Mention guix-patches@gnu.org in 'HACKING'....Ludovic Courtès
2017-01-30maint: Fix invalid calls to 'info'....Mathieu Lirzin
2017-01-04doc: Add a Git hook that verifies signatures before pushing....Leo Famulari
2016-07-24doc: Explain how to set up Git for signing....Ludovic Courtès
2016-07-14doc: Mention commit signatures in HACKING....Leo Famulari