From 457bc7438a4f0801dbf332fa2369248bddf5da0c Mon Sep 17 00:00:00 2001 Message-Id: <457bc7438a4f0801dbf332fa2369248bddf5da0c.1678309546.git.dev@jpoiret.xyz> From: Josselin Poiret Date: Wed, 8 Mar 2023 18:31:52 +0100 Subject: [PATCH] Add environment variable for library directories AGDA_LIBDIRS is a new environment colon-separated variable for site libraries. Agda will look for .agda-lib files directly inside direct descendants of these. --- src/full/Agda/Interaction/Library.hs | 16 ++++++++++++++-- 1 file changed, 14 insertions(+), 2 deletions(-) diff --git a/src/full/Agda/Interaction/Library.hs b/src/full/Agda/Interaction/Library.hs index 09c1f2a82..774cc3e74 100644 --- a/src/full/Agda/Interaction/Library.hs +++ b/src/full/Agda/Interaction/Library.hs @@ -323,13 +323,25 @@ getInstalledLibraries overrideLibFile = mkLibM [] $ do raiseErrors' [ LibrariesFileNotFound theOverrideLibFile ] return [] Right file -> do - if not (lfExists file) then return [] else do + siteLibDirs <- liftIO $ fromMaybe [] . fmap splitAtColon . lookup "AGDA_LIBDIRS" <$> getEnvironment + siteLibs <- liftIO $ concat <$> mapM findSiteLibs siteLibDirs + if not (lfExists file) then parseLibFiles Nothing $ nubOn snd ((0,) <$> siteLibs) else do ls <- liftIO $ stripCommentLines <$> UTF8.readFile (lfPath file) files <- liftIO $ sequence [ (i, ) <$> expandEnvironmentVariables s | (i, s) <- ls ] - parseLibFiles (Just file) $ nubOn snd files + parseLibFiles (Just file) $ nubOn snd (files ++ fmap (0,) siteLibs) `catchIO` \ e -> do raiseErrors' [ ReadError e "Failed to read installed libraries." ] return [] + where splitAtColon :: String -> [String] + splitAtColon "" = [] + splitAtColon str = case break (==':') str of + (a, _:b) -> a : splitAtColon b + (a, "") -> [a] + findSiteLibs :: String -> IO [String] + findSiteLibs dir = do + subDirs <- filterM doesDirectoryExist =<< map (dir ) <$> listDirectory dir + subFiles <- mapM (\dir -> map (dir ) <$> listDirectory dir) subDirs + return $ concatMap (filter (List.isSuffixOf ".agda-lib")) subFiles -- | Parse the given library files. -- base-commit: 183534bc41af5a53daf685122997dc98883f2be2 -- 2.39.1 ntent'>
AgeCommit message (Expand)Author
2023-03-30system: hurd: Use shepherd-0.8 in the package list....Josselin Poiret
2023-03-03services: base: Deprecate 'syslog-service' procedure....Bruno Victal
2022-11-28system: hurd: Create more ttys....Ludovic Courtès
2022-04-08system: hurd: Fix bogus 'initrd-modules' field....Ludovic Courtès
2022-03-09system: hurd: Move the Shepherd before the Hurd in %BASE-PACKAGES/HURD....Ludovic Courtès
2021-12-12services: Define '%loopback-static-networking'....Ludovic Courtès
2021-12-12services: Define '%qemu-static-networking'....Ludovic Courtès
2021-12-12services: static-networking: Change interface to mimic netlink....Ludovic Courtès
2021-10-18system: hurd: Add 'info-reader' to %BASE-PACKAGES/HURD....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-08-12system: install, hurd: Use 'setuid-programs'....Ludovic Courtès