Fixes a fatal constness error with g++ 4.8.2. --- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100 +++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100 @@ -182,7 +182,7 @@ // Use optimizations in memchr when possible. if (needle_len == 1) - return memchr(haystack, *needle, haystack_len); + return (void *) memchr(haystack, *needle, haystack_len); // Minimizing the worst-case complexity: // Let n = haystack_len, m = needle_len. href='/'>index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/transformations.scm
AgeCommit message (Expand)Author
2021-09-08transformations: Git tags and 'git describe' style IDs are used as version....Marius Bakke
2021-08-11transformations: 'with-patch' works on non-origin sources....Ludovic Courtès
2021-03-05profiles: 'package->manifest-entry' preserves transformations by default....Ludovic Courtès
2021-01-19transformations: Add '--with-latest'....Ludovic Courtès
2020-12-27transformations: Add '--with-patch'....Ludovic Courtès
2020-12-21tests: Check the effect of '--without-tests' on implicit inputs....Ludovic Courtès
2020-10-31guix build: Move transformation options to (guix transformations)....Ludovic Courtès