Fixes a fatal constness error with g++ 4.8.2.
--- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
+++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
@@ -182,7 +182,7 @@
// Use optimizations in memchr when possible.
if (needle_len == 1)
- return memchr(haystack, *needle, haystack_len);
+ return (void *) memchr(haystack, *needle, haystack_len);
// Minimizing the worst-case complexity:
// Let n = haystack_len, m = needle_len.
x/'>guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-01-11 | Update mailmap....* .mailmap: Add entry for Zheng Junjie.
| Leo Famulari |
2021-11-06 | Update mailmap and copyright assignments for Liliana Marie Prikler....Use full names everywhere.
* .mailmap: Use full name for Liliana Marie Prikler.
* gnu/packages/zig.scm: Likewise.
| Liliana Marie Prikler |
2021-09-06 | Update mailmap....* .mailmap: Add entry for Liliana Marie Prikler.
| Liliana Marie Prikler |
2021-09-04 | Update mailmap....* .mailmap: Alias all my contributions to the same identity.
| Marius Bakke |
2021-07-27 | Update mailmap....* .mailmap: Add entry for Christine Lemmer-Webber.
| Leo Famulari |
2021-07-08 | mailmap: Update entries for Matthew James Kraai....* .mailmap: Change name for Matthew James Kraai.
* gnu/packages/lisp-xyz.scm, gnu/packages/python-xyz.scm,
gnu/packages/rust.scm: Likewise.
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
| Matthew James Kraai |
2021-06-23 | gnu: Add Sollya....* gnu/packages/algebra.scm (sollya): New variable.
* .mailmap: Adjust "proper email" for `git commit`.
| Eric Bavier |
2021-04-21 | Update email address for Kei....* .mailmap: Remove obsolete email for Kei.
| Kei Kebreau |