Fixes a fatal constness error with g++ 4.8.2.
--- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
+++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
@@ -182,7 +182,7 @@
// Use optimizations in memchr when possible.
if (needle_len == 1)
- return memchr(haystack, *needle, haystack_len);
+ return (void *) memchr(haystack, *needle, haystack_len);
// Minimizing the worst-case complexity:
// Let n = haystack_len, m = needle_len.
/cgit.png' alt='cgit logo'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-02-11 | gnu: php: Update to 8.2.2....* gnu/packages/php.scm (php): Update to 8.2.2.
* gnu/packages/patches/php-curl-compat.patch: Remove file.
* gnu/packages/patches/php-bug-74093-test.patch: Remove file.
* gnu/packages/patches/php-fix-streams-copy-length.patch: New file.
* gnu/local.mk (dist_patch_DATA): Remove them. Add it.
| Julien Lepiller |