Fixes a fatal constness error with g++ 4.8.2.
--- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
+++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
@@ -182,7 +182,7 @@
// Use optimizations in memchr when possible.
if (needle_len == 1)
- return memchr(haystack, *needle, haystack_len);
+ return (void *) memchr(haystack, *needle, haystack_len);
// Minimizing the worst-case complexity:
// Let n = haystack_len, m = needle_len.
>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-12-18 | gnu: ruby-execjs: Use node-lts instead of node....* gnu/packages/ruby.scm (ruby-execjs)[native-inputs]: Replace node by
node-lts.
Change-Id: If7ff42d9865d79c23560fb190db4fdce9ecc621c
| Jelle Licht |
2024-11-22 | gnu: ruby-net-smtp: Fix tests....The tests where failing due to the SSL certificate being used expired.
Regenerate the certificate running the check phase.
* gnu/packages/ruby.scm (ruby-net-smtp): Fix check phase.
Change-Id: I8bd72f2e929f496996f6fd88b13a4d95837273da
| Javier Olaechea |
2024-11-03 | gnu: ruby-ethon: Fix libcurl detection at runtime....* gnu/packages/ruby.scm (ruby-ethon)[arguments]<#:phases>: Add phase
'libcurl-use-absolute-reference.
| Nicolas Graves |
2024-08-31 | gnu: ruby@2.7: Ungraft....* gnu/packages/ruby.scm (ruby-2.7): Update to 2.7.8.
[replacement]: Remove.
(ruby-2.7-fixed): Remove.
Change-Id: I96c8542f606dddda75fcf897dac8a38d6d4d7051
| Ludovic Courtès |
2024-08-28 | gnu: ruby-rdoc: Update to 6.7.0....* gnu/packages/ruby.scm (ruby-rdoc): Update to 6.7.0.
[arguments]<#:phases>: Remove patch for gemspec file.
[native-inputs]: Add ruby-test-unit-ruby-core.
Change-Id: I605f1e79d96ca35029280909e0c2e4c9884c682c
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| gemmaro |
2024-08-14 | gnu: Add ruby-gemtext....* gnu/packages/ruby.scm (ruby-gemtext): New variable.
Change-Id: I21957517a1a3be6b0f5d61a7ba1c8420a884a641
Signed-off-by: jgart <jgart@dismail.de>
| gemmaro |