Fixes a fatal constness error with g++ 4.8.2. --- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100 +++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100 @@ -182,7 +182,7 @@ // Use optimizations in memchr when possible. if (needle_len == 1) - return memchr(haystack, *needle, haystack_len); + return (void *) memchr(haystack, *needle, haystack_len); // Minimizing the worst-case complexity: // Let n = haystack_len, m = needle_len. ex : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-shell.sh
AgeCommit message (Expand)Author
2023-12-06shell: ‘--development’ honors ‘--system’....Ludovic Courtès
2023-08-25tests: guix-shell: Use bash instead of user's $SHELL....Josselin Poiret
2023-04-21tests: Fix checks for expected failures....Eric Bavier
2022-11-15guix: shell: Add '--symlink' option....Maxim Cournoyer
2022-09-04store: Open daemon connections with SOCK_CLOEXEC....Ludovic Courtès
2022-02-18profiles: 'profile-derivation' rejects unsupported packages....Ludovic Courtès
2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe
2021-12-10shell: When using '-D -f', '-D' has no effect on remaining packages....Ludovic Courtès
2021-11-18shell: Adjust test to expect C_INCLUDE_PATH, not CPATH....Ludovic Courtès
2021-10-30shell: Error out when an unauthorized guix.scm/manifest.scm is found....Ludovic Courtès
2021-10-25shell: By default load the local 'manifest.scm' or 'guix.scm' file....Ludovic Courtès
2021-10-25Add 'guix shell'....Ludovic Courtès